Horizontal padding ignored on a button with text-overflow: ellipsis

RESOLVED DUPLICATE of bug 1010675

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 1010675
5 years ago
2 years ago

People

(Reporter: mik01aj, Unassigned)

Tracking

23 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1588.0 Safari/537.36

Steps to reproduce:

See this fiddle: http://jsfiddle.net/CtqbA/


Actual results:

The second .x (the one with button.x) shows text flowing out of content-box (yellow).


Expected results:

I expected all .x to mantain the same geometry.
(Reporter)

Comment 1

5 years ago
Here's a simpler case, without text-overflow: ellipsis:
http://jsfiddle.net/CtqbA/2/

Both divs look correct, but the button has misplaced text and ignores box-sizing: border-box.

Comment 2

5 years ago
Maybe dupe of Bug 703786

Updated

5 years ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
Buttons purposefully allow their text to overflow into their padding, because otherwise sites break due to styling buttons with too-small widths for the default padding...
(In reply to Boris Zbarsky [:bz] from comment #3)
> Buttons purposefully allow their text to overflow into their padding,
> because otherwise sites break due to styling buttons with too-small widths
> for the default padding...

What is it that makes other UAs not break on those sites?
IE also adjusts their default padding in that situation.  But their default padding is some sort of non-CSS padding (e.g. setting "padding: 0" does not make it go away).

In Chrome, things just break.

Comment 6

3 years ago
Please fix this bug, all the other browsers behave as expected - not ignoring padding.
http://jsfiddle.net/7g5akaay/1/

Comment 7

3 years ago
Now firefox matches the expectations in this bug... Reopen this if you still see the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 8

2 years ago
When observing the fiddle http://jsfiddle.net/7g5akaay/1/ in FF 44, IE, Chrome, and Safari, behavior is consistent and "correct" (behaves as expected). 

Though, in 38.4 and 38.5 (ESR), this defect is still reproducible (padding being ignored on when button has textContent). Is there a plan to patch this ESR release?

Updated

2 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1010675
You need to log in before you can comment on or make changes to this bug.