Crash [@ mozilla::widget::AudioSession::StopInternal() ] unplugging USB headset

RESOLVED FIXED

Status

()

Core
Widget: Win32
P1
critical
RESOLVED FIXED
4 years ago
11 months ago

People

(Reporter: ted, Unassigned)

Tracking

({crash})

22 Branch
x86
Windows 7
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
I unplugged my USB headset and Firefox crashed:

 	00000000()	
>	moz6E67.tmp!mozilla::widget::AudioSession::StopInternal()  Line 301	C++
 	moz6E67.tmp!mozilla::widget::AudioSession::OnSessionDisconnectedInternal()  Line 428	C++
 	moz6E67.tmp!nsRunnableMethodImpl<void (__thiscall nsRefreshDriver::*)(void),1>::Run()  Line 358	C++
 	moz6E67.tmp!nsThread::ProcessNextEvent(bool mayWait=true, bool * result=0x002af08f)  Line 628	C++
 	moz6E67.tmp!NS_ProcessNextEvent(nsIThread * thread=0x010182e0, bool mayWait=true)  Line 238 + 0x1f bytes	C++
 	moz6E67.tmp!mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate * aDelegate=0x000410e0)  Line 116 + 0xa bytes	C++
 	moz6E67.tmp!MessageLoop::RunHandler()  Line 214	C++
 	moz6E67.tmp!MessageLoop::Run()  Line 188	C++
 	moz6E67.tmp!nsBaseAppShell::Run()  Line 163	C++
 	moz6E67.tmp!nsAppShell::Run()  Line 112 + 0x8 bytes	C++
 	moz6E67.tmp!nsAppStartup::Run()  Line 270	C++
 	moz6E67.tmp!XREMain::XRE_mainRun()  Line 3871 + 0xa bytes	C++
 	moz6E67.tmp!XREMain::XRE_main(int argc=0x00000001, char * * argv=0x01ea1f30, const nsXREAppData * aAppData=0x002af39c)  Line 3939 + 0x6 bytes	C++
 	moz6E67.tmp!XRE_main(int argc=0x00000001, char * * argv=0x01ea1f30, const nsXREAppData * aAppData=0x002af39c, unsigned int aFlags=0x00000000)  Line 4152 + 0xd bytes	C++
 	moz6E85.tmp!do_main(int argc=0x00000001, char * * argv=0x00000000, nsIFile * xreDirectory=0x02018100)  Line 275 + 0x19 bytes	C++
 	moz6E85.tmp!NS_internal_main(int argc=0x00000001, char * * argv=0x01ea1f30)  Line 635 + 0xd bytes	C++
 	moz6E85.tmp!wmain(int argc=0x00000000, wchar_t * * argv=0x01ea1b20)  Line 112	C++
 	moz6E85.tmp!__tmainCRTStartup()  Line 552 + 0x17 bytes	C
 	kernel32.dll!@BaseThreadInitThunk@12()  + 0x12 bytes	
 	ntdll.dll!___RtlUserThreadStart@8()  + 0x27 bytes	
 	ntdll.dll!__RtlUserThreadStart@8()  + 0x1b bytes	

Looks like it had a NULL this in the top frame. Refcounting issue?
(Reporter)

Updated

4 years ago
Crash Signature: [@ mozilla::widget::AudioSession::StopInternal() ]

Updated

2 years ago
Crash Signature: [@ mozilla::widget::AudioSession::StopInternal() ] → [@ mozilla::widget::AudioSession::StopInternal() ] [@ mozilla::widget::AudioSession::StopInternal ]
Component: Audio/Video → Widget

Updated

2 years ago
Crash Signature: [@ mozilla::widget::AudioSession::StopInternal() ] [@ mozilla::widget::AudioSession::StopInternal ] → [@ mozilla::widget::AudioSession::StopInternal() ] [@ mozilla::widget::AudioSession::StopInternal ] [@ @0x0 | mozilla::widget::AudioSession::StopInternal ]
The volume for this signature is still quite high: ~5000 crashes in the past 28 days.

Jim, Kyle, can either of you take a look please?
Severity: normal → critical
Component: Widget → Widget: Win32
Flags: needinfo?(khuey)
Flags: needinfo?(jmathies)
Keywords: crash
I'm unlikely to be able to look at this anytime soon.
Flags: needinfo?(khuey)

Comment 4

2 years ago
I can try to slip this in someplace. If not I'll get it into platform int work.
Flags: needinfo?(jmathies)

Updated

2 years ago
Keywords: leave-open

Comment 5

2 years ago
nm, filing a separate bug.
Keywords: leave-open

Updated

2 years ago
Depends on: 1268233

Comment 6

2 years ago
should be fixed by bug 1268233.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
This is still reproducible on Windows 7 x64 and Mac OS X 10.11.6 platforms with latest Nightly 54.0a1 (2017-02-09) using the following steps:
1. Launch Firefox
2. Go to https://apprtc.appspot.com/, create a room, provide the camera and microphone permissions and join it
3. Join the same room from another station
4. Unplug the USB headset
5. Connect back the USB headset
6. Refresh the page in order to reestablish the call

I've filed a new bug to track this: bug 1338504. Jim, what's your take on this?
Flags: needinfo?(jmathies)

Updated

11 months ago
Flags: needinfo?(jmathies)
Priority: -- → P1

Updated

11 months ago
Blocks: 1338504
You need to log in before you can comment on or make changes to this bug.