If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

style award notification emails

RESOLVED FIXED in 2013Q3

Status

support.mozilla.org
General
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: willkg, Assigned: rehan)

Tracking

unspecified
2013Q3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=badges p=3 s=2013.19)

Attachments

(1 attachment)

Bug #896137 adds badge infrastructure to Kitsune.

It also added .ltxt and .html templates for award notifications which get sent to the awardee. These two templates look like I wrote them. This bug covers:

1. figuring out what they should really look like
2. figuring out strings and messaging
3. making them look less ugly
4. providing whatever infrastructure is required to disable notification of future award emails using the url at the bottom of all SUMO emails
Blocks: 897057
Priority: -- → P2
Target Milestone: --- → 2013Q3
A bunch of figuring out to do, so 3pts to make sure enough time is blocked out.
Whiteboard: u=contributor c=badges p= s=2013.backlog → u=contributor c=badges p=3 s=2013.18
(Assignee)

Updated

4 years ago
Assignee: nobody → rdalal
Duplicate of this bug: 914126
(Assignee)

Comment 3

4 years ago
Probably not going to get this done this sprint, should probably drop to the next one.
Moving this to next sprint per comment 3.
Whiteboard: u=contributor c=badges p=3 s=2013.18 → u=contributor c=badges p=3 s=2013.19
(Assignee)

Comment 5

4 years ago
Created attachment 809909 [details]
Screen Shot 2013-09-25 at 10.52.54 AM.png

See screenshot. Is that okay?
Flags: needinfo?(a.topal)

Updated

4 years ago
Flags: needinfo?(a.topal)

Comment 6

4 years ago
Love it! Can we have "I have no idea how you did that, you rock!"?
(Assignee)

Comment 7

4 years ago
That text is actually set at the time when the badge is awarded. It's not hard coded into the email.
(Assignee)

Comment 8

4 years ago
Also this is totally a fake badge! :)
This looks great to me :)

Comment 10

4 years ago
this looks very cool :)

So we'll get to text every badge differently?
(Assignee)

Comment 11

4 years ago
Every time a badge is awarded you can enter a "description" of why the badge was awarded. This is what gets added to the email.

Comment 12

4 years ago
Great! Thanks a lot Rehan
(Assignee)

Comment 13

4 years ago
Landed:
https://github.com/mozilla/kitsune/commit/98d59bdaf890fd30e323a880d5eb8bb80ecdfa9c

Pushed to prod at Ricky, this morning.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.