[Buri][Language][FOTA]Some string don't translate in French and Chinese

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::SMS
P1
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.204
 Firefox os  v1.1
  Mozilla build ID:20130826041201
 
 DEFECT DESCRIPTION:
  Some string don't translate in French and Chinese
 
  REPRODUCING PROCEDURES:
  1.Set the phone system language is French/Chinese,receive a message containing an email address,tap the email address,pop up menu item,find "send emial" can't translate into French/Chinese,Please see the snapshot1--ko1
  2.Set the phone system language is Chinese,MS don't have SIM card,type recipient and txt content,tap "send" key,pop up "SIM card error",please see the snapshot2--ko2
  3.Set the phone system language is Chinese,enter create a new message interface,find "Message" can't translate into Chinese,please see the snapshot3--ko3
 
  EXPECTED BEHAVIOUR:
  ko1:"send email" should translate into French/Chinese.
  ko2:"SIM card error" should translate into Chinese.
  ko3:"Message" should translate into Chinese.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:free test
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:medium
 
  REPRODUCING RATE:5/5
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Created attachment 797603 [details]
PR515332.snapshot3
(Reporter)

Comment 2

5 years ago
Clone from brother
(Reporter)

Comment 3

5 years ago
Created attachment 797605 [details]
PR515332.snapshot3
(Reporter)

Comment 4

5 years ago
Clone from brother
(Reporter)

Comment 5

5 years ago
Created attachment 797607 [details]
PR515332.snapshot2
(Reporter)

Comment 6

5 years ago
Clone from brother
(Reporter)

Comment 7

5 years ago
Created attachment 797608 [details]
PR515332.snapshot1
(Reporter)

Comment 8

5 years ago
Clone from brother

Updated

5 years ago
Component: Gaia → Gaia::SMS
I think these are problems in the chinese translations, because all these texts are translatable in 1.1 as far as I know.

Can you check this still happens now ? And if this still happens we'll ask localizers.
Flags: needinfo?(sync-1)
Keywords: qawanted
Of course, test with a multilocale build, as the translations in the Gaia repository are wrong.

Updated

4 years ago
QA Contact: sparsons

Comment 11

4 years ago
Unable to reproduce on Buri Master Build ID: 20131015040202

Gaia   17e871ae1f82699793e3cd28acda805ba724a8b6
SourceStamp febfe3c7732b
BuildID 20131015040202
Version 27.0a1
Keywords: qawanted

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(sync-1)
You need to log in before you can comment on or make changes to this bug.