java plugin install broken for Windows ME

RESOLVED FIXED

Status

SeaMonkey
General
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Clark O. Morgan, Assigned: asa)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I do most of my e-commerce buying with IE on Windows ME.  I decided to try and
purchase a weedwacker repair part today using Mozilla 0.9.2 on Windows ME.

I browsed www3.sears.com (their parts direct web page) and entered 358799260 as
the model number of the weed wacker.  An intermediate web page was presented
that showed this was a Craftsman Weedwacker and gave me the opportunity to
confirm by clicking Continue, which I did.  On the next web page, I clicked the
radio button that allowed me to view a diagram of the weedwacker's drive shaft
and cutter head.

A popup window was displayed with the message:  Click here to get plugin 

So I clicked as directed to start installing the Java 2 plugin for Windows.

The installation ran to completion.  Afterward, I once again tried to view the
diagram of the weedwacker's drive shaft and cutter head.  I was once again
prompted to "click here to get plugin".  I exited Mozilla and restarted the
browser, at which point I received an audible bell and an error message about
needing to restart to allow something to complete installation.  So I rebooted
my computer and restarted Mozilla--no error now.  I revisited www3.sears.com and
tried once more to view the drive shaft and cutter head.  I was once again
prompted to "click here to get plugin".  Well, obviously, the install didn't work.

I viewed the installed Mozilla Plugins (Help -> About Plugins) and noticed that
Mozilla did _not_ list a Java plugin.

However, if I open the Windows ME control panel and invoke the "Add/Remove
Programs" applet, I see "Java 2 Runtime Environment Standard Edition v1.3.0._01"
listed as an installed app.
It appears to me that the Java Plugin installation is not working for Mozilla
0.9.2 .
Does it work if you do this :

(from the 0.9.2 release notes)
Windows: If you're using the Installer build and you already have JRE 1.3.0_01 
on your system Mozilla should recognize it. If it doesn't
recognize it then follow the copy instructions for the zip builds. 

If you're using the win32.zip or talkback.zip builds After the JRE is installed 
on your machine, copy NPJava130_01.dll, NPJava130_01a.dll,
NPJava130_01b.dll, NPJava130_01c.dll, and NPOJI600.dll from the install 
directory (something like C:\Program
Files\JavaSoft\JRE\1.3.0_01\bin) to your Mozilla plugins directory (something 
like C:\Program Files\Mozilla 0.9.2\bin\plugins). 
(Reporter)

Comment 2

17 years ago
Yes, the workaround in the previous comment (copy DLLs from one dir to another)
fixed the bug.

Sorry to bother you folks.

- Clark
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.