[e.me][feature] Dedup apps

RESOLVED FIXED

Status

Firefox OS
Gaia::Everything.me
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: ranbena, Assigned: ranbena)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Tow types of deduping in Evme results are needed:
1. Hide Marketplace suggestion if app is already installed
2. Hide Cloud result if already bookmarked to Collection/Hoemscreen and appears above the line
(Assignee)

Updated

5 years ago
Assignee: nobody → ran
Created attachment 797860 [details]
Patch - redirect to commit
(Assignee)

Updated

5 years ago
Blocks: 910302, 910336
A third type of dedup was added:
3. Hide Cloud result if an there's already a equivalent "native" app installed.

STR:
1. Go to Collection "Social".
2. The Twitter cloud app appears in the cloud results.
3. Install the Twitter app from the Marketplace.
4. Go back to Collection "Social".

Now Twitter installed app appears on top, and the Twitter cloud app doesn't appear at all.
Created attachment 812735 [details]
Patch - redirect to github PR
Attachment #797860 - Attachment is obsolete: true
Attachment #812735 - Flags: review?(evyatar)
Missing one case - what should happen if I bookmark twitter, and then install the app from the marketplace? Should it get deduped or not? Should I now see both installed Twitter and bookmarked one, or ONLY the installed one?
IMO this case should not be deduped. We are deduping only suggestions - never user installed apps / bookmarks.
If the user actively installed both - both should appear.

This means I should make sure pinned cloudapps won't get deduped.
All looks well, except for the following case:

STR:
1. Searched for "twitter"
2. Installed the app from the marketplace (from the search results)
3. Closed the marketplace

Result:
The app was removed from the search results above the line, and was left only BELOW the line as a cloud app.
* NOTE - this works well if closing the search and re-doing it.

Expected:
The app should be shown as installed above the line, and the cloud app removed (deduped) - how it looks after re-searching for "twitter".
Good news - pinned cloudapps do not get deduped (cause they're considered "static apps")

(In reply to Ran Ben Aharon (Everything.me) from comment #5)
> IMO this case should not be deduped. We are deduping only suggestions -
> never user installed apps / bookmarks.
> If the user actively installed both - both should appear.
> 
> This means I should make sure pinned cloudapps won't get deduped.
Comment on attachment 812735 [details]
Patch - redirect to github PR

r+ once minor GH comments are addressed.
Attachment #812735 - Flags: review?(evyatar) → review+
Evyatar, I've updated the branch with the required feature.
STR:
1. Search for "twitter".
2. Click the marketplace suggestion
3. Install the app
4. Return to search (click the "x")

Now the Installed app appears, and the marketplace suggestion and equivalent cloud app do not.
(Assignee)

Updated

5 years ago
Attachment #812735 - Flags: review?(crdlc)
Attachment #812735 - Flags: review?(crdlc) → review+
Landed on master
https://github.com/mozilla-b2g/gaia/commit/db5776aad213f9ddba82810ff7f1b366f9492454
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
blocking-b2g: --- → koi?
removing koi? since e.me 1.2 features are delayed for future version
blocking-b2g: koi? → ---
(Assignee)

Updated

4 years ago
Duplicate of this bug: 910336
You need to log in before you can comment on or make changes to this bug.