Closed Bug 911204 Opened 8 years ago Closed 8 years ago

Thumbnail Zoom Plus crashes Nightly 0830 build

Categories

(Core :: JavaScript Engine, defect)

26 Branch
x86_64
Windows 8
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: Fanolian+BMO, Assigned: bhackett1024)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130830030205

Steps to reproduce:

Install Thumbnail Zoom Plus in a new profile. Restart Browser.
(https://addons.mozilla.org/firefox/addon/thumbnail-zoom-plus/versions/)


Actual results:

Nightly crashes.
Crash ID: https://crash-stats.mozilla.com/report/index/7b129043-7802-4bed-9db4-796352130830
Crash Signature: moz_abort | arena_run_reg_dalloc | arena_dalloc_small | arena_dalloc | je_free | js::frontend::CompileError::~CompileError()
Keywords: crash
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/e3d47ec31c30
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130829125628
Bad:
http://hg.mozilla.org/mozilla-central/rev/8c5a94ba1096
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130829134141
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e3d47ec31c30&tochange=8c5a94ba1096

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f1e2f0c0b542
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130829084235
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b1001a1e906a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130829091129
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f1e2f0c0b542&tochange=b1001a1e906a

Suspected: 
f45469113804	Brian Hackett — Bug 908699 - Allow generating parse errors and warnings when off the main thread, r=billm.
Assignee: nobody → general
Blocks: 908699
Status: UNCONFIRMED → NEW
Component: Untriaged → JavaScript Engine
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Severity: normal → critical
Crash Signature: moz_abort | arena_run_reg_dalloc | arena_dalloc_small | arena_dalloc | je_free | js::frontend::CompileError::~CompileError() → [@ moz_abort | arena_run_reg_dalloc | arena_dalloc_small | arena_dalloc | je_free | js::frontend::CompileError::~CompileError() ]
I'm the developer of Thumbnail Zoom Plus; let me know if anything the add-on is doing wrong is causing the problem.
Attached patch patchSplinter Review
I didn't try to reproduce this but the problem is probably that the ctor/dtor for CompileError do not behave well when the vector is resized.  This patch heap allocates the errors so that the vector just contains pointers.
Attachment #798546 - Flags: review?(wmccloskey)
Comment on attachment 798546 [details] [diff] [review]
patch

Review of attachment 798546 [details] [diff] [review]:
-----------------------------------------------------------------

I guess this is fine. I filed bug 911806 on CompileError not having an operator=.
Attachment #798546 - Flags: review?(wmccloskey) → review+
https://hg.mozilla.org/mozilla-central/rev/24ffdfbf55d8
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Assignee: general → bhackett1024
Crash Signature: [@ moz_abort | arena_run_reg_dalloc | arena_dalloc_small | arena_dalloc | je_free | js::frontend::CompileError::~CompileError() ] → [@ moz_abort | arena_run_reg_dalloc | arena_dalloc_small | arena_dalloc | je_free | js::frontend::CompileError::~CompileError() ] [@ jemalloc_crash | arena_run_reg_dalloc | arena_dalloc_small | arena_dalloc | arena_bin_malloc_hard | js::frontend::Compile…
Depends on: 928542
No longer depends on: 928542
You need to log in before you can comment on or make changes to this bug.