Closed Bug 911235 Opened 6 years ago Closed 6 years ago

Intermittent robocop focusUrlBar failure | EditText with index 0 is not available!

Categories

(Firefox for Android :: General, defect)

x86
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 915449

People

(Reporter: gbrown, Assigned: gbrown)

Details

(Keywords: intermittent-failure)

Running robocop tests locally, I sometimes get this failure, or a variant, always in focusUrlBar, always on the 2nd or subsequent focusUrlBar call in the test.

08-29 15:01:18.476 I/Robocop (10957): Exception caught during test!
08-29 15:01:18.476 I/Robocop (10957): junit.framework.AssertionFailedError: EditText with index 0 is not available!
08-29 15:01:18.476 I/Robocop (10957): 	at junit.framework.Assert.fail(Assert.java:50)
08-29 15:01:18.476 I/Robocop (10957): 	at junit.framework.Assert.assertTrue(Assert.java:20)
08-29 15:01:18.476 I/Robocop (10957): 	at com.jayway.android.robotium.solo.Waiter.waitForAndGetView(Waiter.java:362)
08-29 15:01:18.476 I/Robocop (10957): 	at com.jayway.android.robotium.solo.Getter.getView(Getter.java:48)
08-29 15:01:18.476 I/Robocop (10957): 	at com.jayway.android.robotium.solo.Solo.getEditText(Solo.java:1475)
08-29 15:01:18.476 I/Robocop (10957): 	at org.mozilla.fennec_mozdev.tests.BaseTest$1.test(BaseTest.java:205)
08-29 15:01:18.476 I/Robocop (10957): 	at org.mozilla.fennec_mozdev.tests.BaseTest.waitForTest(BaseTest.java:315)
08-29 15:01:18.476 I/Robocop (10957): 	at org.mozilla.fennec_mozdev.tests.BaseTest.focusUrlBar(BaseTest.java:202)
08-29 15:01:18.476 I/Robocop (10957): 	at org.mozilla.fennec_mozdev.tests.AboutHomeTest.openAboutHomeTab(AboutHomeTest.java:315)
08-29 15:01:18.476 I/Robocop (10957): 	at org.mozilla.fennec_mozdev.tests.testHistory.testHistory(testHistory.java:33)
08-29 15:01:18.476 I/Robocop (10957): 	at java.lang.reflect.Method.invokeNative(Native Method)
08-29 15:01:18.476 I/Robocop (10957): 	at java.lang.reflect.Method.invoke(Method.java:511)
08-29 15:01:18.476 I/Robocop (10957): 	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
08-29 15:01:18.476 I/Robocop (10957): 	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
08-29 15:01:18.476 I/Robocop (10957): 	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
08-29 15:01:18.476 I/Robocop (10957): 	at org.mozilla.fennec_mozdev.tests.BaseTest.runTest(BaseTest.java:161)
08-29 15:01:18.476 I/Robocop (10957): 	at junit.framework.TestCase.runBare(TestCase.java:134)
08-29 15:01:18.476 I/Robocop (10957): 	at junit.framework.TestResult$1.protect(TestResult.java:115)
08-29 15:01:18.476 I/Robocop (10957): 	at junit.framework.TestResult.runProtected(TestResult.java:133)
08-29 15:01:18.476 I/Robocop (10957): 	at junit.framework.TestResult.run(TestResult.java:118)
08-29 15:01:18.476 I/Robocop (10957): 	at junit.framework.TestCase.run(TestCase.java:124)
08-29 15:01:18.476 I/Robocop (10957): 	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:190)
08-29 15:01:18.476 I/Robocop (10957): 	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:175)
08-29 15:01:18.476 I/Robocop (10957): 	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:555)
08-29 15:01:18.476 I/Robocop (10957): 	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1584)
On the Nexus 4, I often get this failure on testHistory and testTabHistory.
There is a slightly different error message in my report, but I think that's because I was using an earlier version of robotium.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915449
You need to log in before you can comment on or make changes to this bug.