If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mousewheel event not fired correctly in Mountain Lion + Magic Mouse

RESOLVED DUPLICATE of bug 907275

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 907275
4 years ago
4 years ago

People

(Reporter: Michael Kliewe, Unassigned)

Tracking

23 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

I created a small test website. If you scroll up there will be written one line for each "onmousescroll" event that is fired.
http://www.phpgangsta.de/download/wheel.html

It is working as expected on every computer, BUT NOT if you have Mac OS X Mountain Lion 10.8.4 + Magic Mouse.
Using Chrome with that combination works fine, just Firefox behaves different.

We are catching the events to scroll our own "virtual table", this is not working with the combination explained above.


Actual results:

If you have Mac OS X + Magic Mouse and you scroll up in Firefox you only get 1-2 events fired per second. If you scroll slowly then you don't get any events.


Expected results:

Like on every other computer the event should be fired many more times. If you scroll up normally you should get more than 10 events per second.
(Reporter)

Updated

4 years ago

Updated

4 years ago
Component: Untriaged → Event Handling
Product: Firefox → Core
This should be fixed in Firefox Beta ( http://www.mozilla.org/en-US/firefox/channel/#beta ) - can you confirm?

If so, it's probably the same as bug 907275.
(Reporter)

Comment 2

4 years ago
Hi Markus,

yes, it is fixed in Firefox Beta (24.0b7). It seems that bug 907275 is the same, so it is not only the magic mouse but also the magic trackpad on Mountain Lion.

So let's wait until v24 is released, we have to tell the customers to use Chrome until then ;-(

You can mark it as fixed in v24.

Thanks for your hint and help!
Michael
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 907275
You need to log in before you can comment on or make changes to this bug.