If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sdk/context-menu Item image property image not showing on linux

RESOLVED WONTFIX

Status

Add-on SDK
General
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Jack, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.57 Safari/537.36

Steps to reproduce:

On Ubuntu 13.04

Creating a very simple add-on with: "cfx init"

Then having the lib/main.js be something like:

var imageUrl = require("sdk/self").data.url("favicon.ico");
var cm = require("sdk/context-menu");
cm.Item({
  label: "A Mozilla Image",
  image: imageUrl,
  context: cm.SelectorContext("img"),
  contentScript: 'self.on("context", function (node) {' +
                 '  return /mozilla/.test(node.src);' +
                 '});'
});

"cfx run"
right click an image


Actual results:

Linux: no image shows up next to label in the context menu
Windows 8: image correctly shows up next to label in the context menu

No errors in the output of "cfx run"


Expected results:

Linux: the image should have appeared next to the label when getting the context menu on an image
I'll take a look and see what I can find.
Flags: needinfo?(kwierso)
Flags: needinfo?(kwierso) → needinfo?(dtownsend+bugmail)
This is Firefox respecting the Ubuntu system settings where icons for menus are disabled by default. You can see how to turn them on here: http://www.gmjjavadesigns.com/content/ubuntu-1210-how-turn-menu-icons

We wouldn't want to fix this bug as it would violate the system settings.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(dtownsend+bugmail)
Resolution: --- → WONTFIX
(Reporter)

Comment 3

4 years ago
(In reply to Dave Townsend (:Mossop) from comment #2)
> This is Firefox respecting the Ubuntu system settings where icons for menus
> are disabled by default. You can see how to turn them on here:
> http://www.gmjjavadesigns.com/content/ubuntu-1210-how-turn-menu-icons
> 
> We wouldn't want to fix this bug as it would violate the system settings.

Gotcha, makes sense. Thanks for the info. Although it seems like it might be a good idea to expose this to devs using the sdk, so when they do "cfx run" in their terminal they would see something like: "INFO sdk/context-menu 'image' property ignored due to system settings (see x)." Thanks again.
You need to log in before you can comment on or make changes to this bug.