Profiler breaks when navigation happens during toolbox opened

RESOLVED DUPLICATE of bug 904910

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
RESOLVED DUPLICATE of bug 904910
4 years ago
4 years ago

People

(Reporter: fitzgen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Not reproducible all the time.

STR:

open toolbox

select profiler

back navigation

forward navigation

start profiling

expected:

profiling

actual:

nothing

error console:

[21:19:26.138] error occurred while processing 'startProfiler: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIProfiler.StartProfiler]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/actors/profiler.js :: ProfilerActor.prototype.onStartProfiler :: line 86"  data: no] @ resource://gre/modules/devtools/dbg-server.jsm -> resource://gre/modules/devtools/server/main.js:839
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904910
You need to log in before you can comment on or make changes to this bug.