FreeBSD builds doesn't define gethostbyname() properly

RESOLVED FIXED in mozilla1.0

Status

Directory
LDAP C SDK
P2
critical
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: klui, Assigned: dmose)

Tracking

other
mozilla1.0
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.2) Gecko/20010704
BuildID:    0.9.2

The build for FreeBSD has an incorrect reference for gethostbyname(), and
defaults to gethostbyname_r(). The above URL specifies a patch submitted to FreeBSD.

This problem causes Mozilla to exit with an unreferenced entry point for
gethostbyname_r() whenever a name search is done if an LDAP server is defined.

Reproducible: Always
Steps to Reproduce:
0.use FreeBSD
1.define LDAP server
2.create new email message
3.type in the to field


Actual Results:  Mozilla exists with an unreferenced entry point gethostbyname_r()

Expected Results:  Name is searched

FreeBSD has been patched via the ports, but the ultimate fix should be in
Mozilla's codebase.
This causes a crash.  So it's critical.  ccing leaf since this is related to
build config.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: patch, review

Comment 2

17 years ago
This looks like an  LDAP patch change. Over to dmose. 
Assignee: mscott → dmose
(Assignee)

Comment 3

17 years ago
> FreeBSD has been patched via the ports, but the ultimate fix should be in
> Mozilla's codebase.


So a patch already exists?  Can you attach it to this bug?
(Reporter)

Comment 5

17 years ago
Created attachment 42601 [details] [diff] [review]
Patch for directory/c-sdk/ldap/include/portable.h
(Assignee)

Comment 6

17 years ago
r=dmose@netscape.com
Priority: -- → P2
Whiteboard: have patch, r=; awaiting sr=
Target Milestone: --- → mozilla0.9.3
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 7

17 years ago
sr=bienvenu
(Assignee)

Comment 8

17 years ago
Fix checked in on the LDAP C SDK 4.1 branch, so the browser should no longer be
seeing this problem.  Bug over to mhein for possible checkin on SDK 5 mainline.
Assignee: dmose → mhein
Status: ASSIGNED → NEW
(Assignee)

Updated

17 years ago
Component: Networking - General → LDAP C SDK
Product: MailNews → Directory
Target Milestone: mozilla0.9.3 → ---

Comment 9

17 years ago
QA-> Yu-Lian
QA Contact: huang → yulian

Comment 10

17 years ago
adding nsbeta1+ since needed for merge from the LDAP C SDK v4.0
Keywords: nsbeta1+
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 11

17 years ago
Taking for 4.0 -> 5.0 branch merge.
Assignee: mhein → dmose
Keywords: patch, review
Whiteboard: have patch, r=; awaiting sr=
(Assignee)

Comment 12

17 years ago
Fix checked in to ldapcsdk_branch_50.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.