[Browser] Content loads in zoomed out state

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Browser
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: tchung, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [sprintready])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 798018 [details]
b2g_browserShrinkContent.png

Certain conditions will cause the website to load its mobile content into a zoomed out version of the site.    See screenshot.   This is reproducible if you are mixing in cache clearing, force killing app, and launching site for the first time.

BTW, this example is amazon.com, which is loading mobile content, not desktop.

Ben, if this is a gfx/layout bug, please kick it over to them.

Screenshot attached.

Repro:
1) install 1.2 nightly build on Buri
** BuildID 201308300040204
2) launch browser app > settings
3) clear browsing history, and clear cookies/cache
4) force kill Browser app process for clean start
5) relaunch Browser App, and visit URL (ie. www.amazon.com)
6) If this doesnt work, try another trick:

6a) launch 2nd tab, and go to cnn.com.  let page load
6b) switch tabs back to 1st tab.   

7) Verify you hit the shrinked content page

Expected:
- mobile site loads full size
I can reproduce this with the above STR, but only sporadically (perhaps 1 out of every 5 tries). It would be nice to have a more reliable way to reproduce this.
(Reporter)

Comment 2

4 years ago
(In reply to Botond Ballo [:botond] from comment #1)
> I can reproduce this with the above STR, but only sporadically (perhaps 1
> out of every 5 tries). It would be nice to have a more reliable way to
> reproduce this.

i agree, my reproduction was like 20-40% of my tries.  will continue to work on STRs, but it was annoying enough that i believe this regressed and needs attention for 1.2.   in your 20% reproduction, is there enough data that you can work with?

also, if i can provide any useful logging let me know how.  when i repro'd it, i didnt see anything in logcat that would have been beneficial.
I no longer see this with my patch for bug 904533. Of course, given the low repro rate, it's hard to tell whether the problem is really gone or it just didn't happen for me.
Actually, I can still see this occasionally, so I guess bug 904533 didn't fix it :(

One thing I found that reproduces this a bit more often, is at step 6a of the STR to Google "cnn" instead of going to cnn.com. When I do that, the Google search page sometimes loads zoomed out.
need more reliable STR for this to remain a blocker
blocking-b2g: koi? → koi+
Flags: needinfo?(tchung)
Keywords: steps-wanted

Updated

4 years ago
QA Contact: dsubramanian
Note - I was able to see this when I was testing loading up bugzilla.mozilla.org. Try navigating around bugzilla.mozilla.org on your phone - you should see this bug happen.
(Reporter)

Comment 7

4 years ago
Created attachment 805644 [details]
Screenshot 2

Here's another screenshot.   Hit it again on today's build

STR
1) install nightly 1.2 build on Buri: 20130916040205
2) launch browser, clear all cookies and history
3) exit, long tap home screen, and force kill browser app
4) relaunch browser, and type in "cnn" in the URL bar.  Search
5) zoomed out test results for CNN on google search
Flags: needinfo?(tchung)
(Reporter)

Updated

4 years ago
Keywords: steps-wanted

Comment 8

4 years ago
Created attachment 805688 [details]
20130916_134918.jpg

I was able to reproduce this issue 4/5 times based on the description of the bug (steps 1-5) I was able to see the shrinked content page of the following pages
1. www.target.com
2. www.firefox.com
3. www.Amazon.com

While investing this issue, I was also able to see that the issue stopped occuring after the 30th build. 
It does not reprodece on today's build.

Reproduces on Buri Build ID: 20130830040204
Gecko: http://hg.mozilla.org/mozilla-central/rev/c7459bc8e449
Gaia: 407fbfb6a9de68ec4db2f0f3dc6c67463e293f47
Platform Version: 26.0a1

Does NOT repro on Buri Build ID: 20130916040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/c4bcef90cef9
Gaia: a0079597d510ce8ea0b9cbb02c506030510b9eeb
Platform Version: 26.0a1

Comment 9

4 years ago
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/57244904
Whiteboard: sprintready
Whiteboard: sprintready → [sprintready]
I cant reproduce this on master, and given it cant be reproduced in a proper triage, closing wfm https://bugzilla.mozilla.org/show_bug.cgi?id=911345#c8
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.