[B2G][Helix][homescreen][shijinde]it has some posibilities that it will stop in the middle between two pages when dragging app icon from one page to another

RESOLVED WONTFIX

Status

P2
blocker
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

【Detail Description*】:it has some posibilities that it will stop in the middle between two pages when dragging app icon from one page to another
【Repro Steps*】:1.At least ,create 10 pages,in desk
		  2. Dragging app icon from one page to another in desk ,repeat several times.
【Expect Result*】:The app move from one page to another
【Real Result*】:it has some posibilities than stoping in the middle between two pages.  
【Test Count*】:5
【Found Count*】:10
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14  
【Gecko commit ID*】: 170f9e477571127cd40997fa2abe262ed43f0e4d 
【Log*】:20130821102442WP_20130819_001.mp4
【Network environment】:
【Resume operation】:
【Carrier】:
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
Priority: -- → P1
(Reporter)

Updated

5 years ago
Severity: normal → blocker
Priority: P1 → P2
(Reporter)

Updated

5 years ago
blocking-b2g: hd? → ---
(Reporter)

Comment 1

5 years ago
Hi, Can you test this problem and give me feedback? this problem is no response 2 months.

Thanks.
Flags: needinfo?(wchang)
Flags: needinfo?(brg)
Summary: [B2G][Helix][homescreen][yangshiqi]it has some posibilities that it will stop in the middle between two pages when dragging app icon from one page to another → [B2G][Helix][homescreen][shijinde]it has some posibilities that it will stop in the middle between two pages when dragging app icon from one page to another

Updated

5 years ago
Flags: needinfo?(wchang)
(Reporter)

Comment 2

5 years ago
Created attachment 822193 [details]
911413_VID_0022.zip.001
(Reporter)

Comment 3

5 years ago
Created attachment 822194 [details]
911413_VID_0022.zip.002
(Reporter)

Comment 4

5 years ago
Created attachment 822195 [details]
911413_VID_0022.zip.003
(Reporter)

Comment 5

5 years ago
 Hi, I can reproduce this bug, and you can see the vedio.

I had found this problem four times today.

Thanks
This is a corner case, you need to have "At least ,create 10 pages,in desk" considering not a blocker. Can you try to see if you can reproduce it on master or v1.2?
Flags: needinfo?(brg) → needinfo?(lecky.wanglei)
(Reporter)

Comment 7

5 years ago
Hi, I don't have V1.2 version, about the pages number, I can create more than 20 pages, So Can i create more more? Why don't We limit the number of pages?

5 pages? 10 pages?

I think users nerver use over 10 pages.
Flags: needinfo?(lecky.wanglei)
(Reporter)

Comment 8

5 years ago
Hi, I think this bug is not relate to the pages, you can see the second vedio.

The phone has three pages, and I want to add one page, then find the bug
(Reporter)

Comment 9

5 years ago
Created attachment 822704 [details]
911413_vedio2.3gp
(In reply to lecky from comment #9)
> Created attachment 822704 [details]
> 911413_vedio2.3gp

The video is different from the description you have in comment 0. Is it a different problem?

Can you also make sure you reproduce this on a Mozilla build?

Thanks.
I cannot reproduce it in my helix device with B004 build.
Can you please included the STR?
(Reporter)

Comment 12

5 years ago
Hi, I used unconventional operation and moved an icon out-of-order in 911413_vedio2.3gp. 

about the comment 0, I create about 20 pages, and test one day, reproduce 2 times.

so the probability is very low. 

But I found this problem happend everytimes when I moved an icon to the last pages which will be created automatically.

and if you moved qucikly or the screen changed slowly, maybe can reproduce the problem. 

I can't reporduce this problem everytime. so I can't write the detailed steps.

maybe need doing again and again.

Thanks
(Reporter)

Comment 13

5 years ago
Hi, I had got the error log. you can see the attachment. Also I had attached the OK log.

I output the log like 
01-06 06:10:08.089: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- "function"
01-06 06:10:08.529: INFO/GeckoDump(419): ----sjd---- dock.js-- "function"
01-06 06:10:08.539: INFO/GeckoDump(419): ----sjd---- grid.js-- "function"

you can filter 'sjd'.

if the phone has many apps, the bug will be reproduced easy.

I found the phone stop in "dragdrop.js-- overIconGrid" function in error log.

Thanks
(Reporter)

Comment 14

5 years ago
Hi, I analyse the log, find when the icon was moved to the last page, and quick move to forward page, then the bug happened.

and you can compare error log with ok log.

I attach some log and write here.

error log (fragment)
01-06 06:41:22.579: INFO/GeckoDump(419): ----sjd---- grid.js-- togglePagesVisibility start = 19end21 
01-06 06:41:22.619: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- onNavigationEnd

---- NOTE: the icon in the last page, the phone received an error event "onMove", the right is "onEnd".
becase I quickly move to forward page.

01-06 06:41:22.889: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- onMove
01-06 06:41:22.889: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- getPage
01-06 06:41:22.889: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- handleMove page = [object Object] x = 319 y = 287
01-06 06:41:22.889: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- overIconGrid
01-06 06:41:22.889: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- getPage
01-06 06:41:22.899: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- move
01-06 06:41:22.959: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- onMove
01-06 06:41:22.959: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- getPage
01-06 06:41:22.959: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- handleMove page = [object Object] x = 319 y = 287
01-06 06:41:22.969: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- overIconGrid
01-06 06:41:22.969: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- getPage
01-06 06:41:22.969: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- overIconGrid
01-06 06:41:22.969: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- onEnd
01-06 06:41:22.969: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- stop
01-06 06:41:22.969: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- getPage
01-06 06:41:22.979: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- move


the ok log (fragment)
01-06 06:24:00.449: INFO/GeckoDump(419): ----sjd---- grid.js-- togglePagesVisibility start = 18end20 
01-06 06:24:00.509: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- onNavigationEnd

-------Note: the last page, the write event is onEnd.


01-06 06:24:00.709: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- onEnd
01-06 06:24:00.709: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- stop
01-06 06:24:00.709: INFO/GeckoDump(419): ----sjd---- dragdrop.js-- getPage
01-06 06:24:01.129: INFO/GeckoDump(419): ----sjd---- dock.js-- onDragStop
01-06 06:24:01.139: INFO/GeckoDump(419): ----sjd---- dock.js-- calculateDimentions
01-06 06:24:01.159: INFO/GeckoDump(419): ----sjd---- dock.js-- rePosition
01-06 06:24:01.159: INFO/GeckoDump(419): ----sjd---- grid.js-- ensurePanning
01-06 06:24:01.159: INFO/GeckoDump(419): ----sjd---- grid.js-- ensurePagesOverflow
01-06 06:24:01.159: INFO/GeckoDump(419): ----sjd---- grid.js-- ensurePageOverflow
01-06 06:24:01.159: INFO/GeckoDump(419): ----sjd---- grid.js-- pageOverflowed
01-06 06:24:01.169: INFO/GeckoDump(419): ----sjd---- grid.js-- ensurePageOverflow
01-06 06:24:01.169: INFO/GeckoDump(419): ----sjd---- grid.js-- pageOverflowed
01-06 06:24:01.169: INFO/GeckoDump(419): ----sjd---- grid.js-- ensurePageOverflow
01-06 06:24:01.169: INFO/GeckoDump(419): ----sjd---- grid.js-- pageOverflowed
01-06 06:24:01.169: INFO/GeckoDump(419): ----sjd---- grid.js-- ensurePageOverflow
01-06 06:24:01.169: INFO/GeckoDump(419): ----sjd---- grid.js-- pageOverflowed
01-06 06:24:01.169: INFO/GeckoDump(419): ----sjd---- grid.js-- ensurePageOverflow
(Reporter)

Updated

5 years ago
Flags: needinfo?(wchang)
(Reporter)

Comment 15

5 years ago
Created attachment 825158 [details]
911413 applogcat-log.1
(Reporter)

Comment 16

5 years ago
Created attachment 825159 [details]
911413 ok--filter sjd.txt
(Reporter)

Comment 17

5 years ago
Created attachment 825160 [details]
911413 scroll error.txt
Was this reproduced on a mozilla build yet?
Flags: needinfo?(wchang)
(Reporter)

Comment 19

5 years ago
Hi, this bug I had reprodeced one time on a mozilla build which I get 20131018.

I created the build which never merge myslef code .

So please check you code that I had given you in case.

Thanks
Flags: needinfo?(wchang)
Hi Evelyn

This is what we looked at yesterday, not blocking but would be good to check the root cause.
Flags: needinfo?(wchang) → needinfo?(ehung)
(Reporter)

Comment 21

5 years ago
Hi, Wayne, 

Can you give me you plan when will you resolve this problem?

HD1.1? or 1.2?

Hi Beatriz, what do you think about this bug?
Flags: needinfo?(wchang)
Flags: needinfo?(brg)
Not blocking on 1.1.
Flags: needinfo?(wchang)

Comment 23

5 years ago
Luke, can you help on digging more? It might be a rendering limit given the fact that there are 10 pages on homescreen.

@William, is it reproducable on mozilla build v1.1 and v1.2?
Flags: needinfo?(whsu)
Flags: needinfo?(lchang)
Flags: needinfo?(ehung)
(In reply to lecky from comment #0)
> 【Detail Description*】:it has some posibilities that it will stop in the
> middle between two pages when dragging app icon from one page to another

According to the description above, I think you meant that the icon will stick between two pages in this situation. But in the video you uploaded, I just noticed that the homescreen page will always return to the last page automatically. Could you please let us know which one is the current problem you are focusing? Thanks.
Flags: needinfo?(lchang) → needinfo?(lecky.wanglei)

Comment 25

5 years ago
This is a legacy problem and a duplicate bug.
We has a workaround to mitigate this issue but we still not yet fixed this problem.
Greg may know the answer.

-----------------------------------------------------------------------
Hi, Greg,

As we told long time ago, you mentioned that the bug might be a gecko rendering issue.
Do you have any finding regarding this problem?
Many thanks!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(whsu) → needinfo?(gweng)
You mean Bug 903969?
I now can't find any related bug.
Maybe we can discuss offline to clarify this, with the help from the Gecko graphic team.
Flags: needinfo?(gweng)
(Reporter)

Comment 27

5 years ago
Hi, Luke, maybe my description is not correct, you can see the vedio.

Thanks
Flags: needinfo?(lecky.wanglei)
(In reply to lecky from comment #21)
> Hi, Wayne, 
> 
> Can you give me you plan when will you resolve this problem?
> 
> HD1.1? or 1.2?
> 
> Hi Beatriz, what do you think about this bug?
Any improvement is welcome in version 1.1hd, but it is not a blocker for the release.
Flags: needinfo?(brg)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.