If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][Language][Dialer]"mobile" will not be translated when switch language at the dialer

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-, b2g-v1.3 affected, b2g-v1.3T affected)

Details

Attachments

(2 attachments)

56.01 KB, application/octet-stream
Details
24.37 KB, image/x-png
Details
(Reporter)

Description

4 years ago
Firefox os  v1.1
  Mozilla build ID:20130826041201
 
 Created an attachment (id=505369)
 PIC1
 
 DEFECT DESCRIPTION:
  No matter what kind of language switching, "mobile" will not be translated
  REPRODUCING PROCEDURES:
  1.Input a number of the contacts to dialer for example name is A and mnumber is 10010;
  2.The dialer automatic matching the number,the numbers in front of "mobile";
  3.Switch the language,"mobile" is still displaed in English-KO.
  EXPECTED BEHAVIOUR:
  Switch the language,"mobile" will change the language
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  Medium
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Clone from brother
(Reporter)

Comment 2

4 years ago
Created attachment 798127 [details]
PR516945.log
(Reporter)

Comment 3

4 years ago
Clone from brother
(Reporter)

Comment 4

4 years ago
Created attachment 798128 [details]
PIC1

Updated

4 years ago
blocking-b2g: --- → 1.3T?
NI :delphine here to see if this is 1.3T specific or happens on 1.3 ?
Flags: needinfo?(lebedel.delphine)
This happens on 1.3 also. 
I do not see a bug on file yet for this specific to 1.3
status-b2g-v1.3: --- → affected
status-b2g-v1.3T: --- → affected
Flags: needinfo?(lebedel.delphine)
This happens also for all other labels, such as Home, Work, etc. None of the labels are translated.
Possibly related to Bug 931119 ? This also happens in SMS
I think we should block on this as the sense here is totally lost to the user, depending on the locale. 
(not only 1.3T, but 1.3 in general)
I absolutely agree that this is confusing and gives the impression of an half backed translation.

As :julienw pointed out in bug 931119, the problem is that we're localizing labels in the Contacts app
https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/contacts/locales/contacts.en-US.properties#L66

To fix this we would probably need to move these strings to /shared, but I don't see it as an easy task (it involves moving strings, which means new strings for localizers).
We would not block on this for 1.3T specifically, whatever decision triage comes-up for https://bugzilla.mozilla.org/show_bug.cgi?id=931119 for 1.3 should be applicable here.
blocking-b2g: 1.3T? → -
This bug is out of date and we suspect that it's no longer valid. If you think this is in error, please reopen it.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.