Don’t load tabs until selected

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: nicolas.barbulesco, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Hello,

I have Firefox 23.0.1 on Mac OS X.

In the Prefs, in the section Tabs, I have “Don’t load tabs until selected” ticked. See this screen photo :
http://pbrd.co/12VRFQ9

I have a tab with a www.deviantart.com page with many beautiful images. I Apple-click many links.

Expected behaviour :

Firefox opens the links in background tabs, without loading them. Firefox will load each tab only when I will activate it. Until then, Firefox remains usable.

Actual behaviour :

Firefox opens the links in background tabs, but loads them at once. Firefox becomes more and more sluggish, and eats more and more memory. Quite soon, Firefox becomes unusable.

Please make Firefox obey this preference. Thank you.

Nicolas

Comment 1

5 years ago
That option is specifically for loading tabs restored on startup, the preference it toggles is called browser.sessionstore.restore_on_demand
It used to be under "When Firefox starts" in the General section instead of the Tabs section, bug 720154 moved it to the Tabs section leading to your misunderstanding.
Bug 792210 has been filed to fix the wording so users will know it only applies to restoring sessions.

Comment 2

5 years ago
Mardeg's explanation is right. Marking the bug as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

5 years ago
(In reply to Mardeg from comment #1)

> That option is specifically for loading tabs restored on startup, the
> preference it toggles is called browser.sessionstore.restore_on_demand
> It used to be under "When Firefox starts" in the General section instead of
> the Tabs section, bug 720154 moved it to the Tabs section leading to your
> misunderstanding.

Mardeg, you are correct regarding my misunderstanding. This pref is in "Tabs", and nothing says that it would apply only to startup.

Now that I know this, I still want this pref of Firefox to do what she says : loading tabs lazily *always*, not only at startup. There is definitely a need for this, I am not the only one.

So this issue is not invalid.

Having this option would be an important enhancement for solving the (poor) reactivity and (huge) memory problems of Firefox.

It would be a good idea to have these two prefs :

 ☑ When restoring tabs at startup, don’t load tabs until selected
 ☑ When creating a background tab, don’t load tab until selected

Thank you,

Nicolas
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

5 years ago
Severity: normal → enhancement

Updated

5 years ago
Blocks: 720154

Updated

5 years ago
Duplicate of this bug: 851775

Updated

5 years ago
Status: UNCONFIRMED → NEW
Component: General → Preferences
Ever confirmed: true
OS: Mac OS X → All
(Reporter)

Updated

5 years ago
Blocks: 565515
This would be a great thing to build as an add-on. This is way too specific to be built into the browser as a preference into the pref dialog and even too specific to be implemented as a hidden preference.
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
Duplicate of this bug: 1246120

Comment 7

3 years ago
(In reply to Tim Taubert [:ttaubert] from comment #5)
> This would be a great thing to build as an add-on. This is way too specific
> to be built into the browser as a preference into the pref dialog and even
> too specific to be implemented as a hidden preference.

Why is it regarded as too specific? It is a feature many would enjoy and many actually expect (not because they are confused by the name of the option to not load tabs automatically on restore. I am sure many people will agree that it is not that specific and actually something very basic that they expect even out of the box.
You need to log in before you can comment on or make changes to this bug.