Media Recording - When a stream ends, media recording should stop recording

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Recording
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: jsmith, Assigned: rlin)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
When a stream being used for recording ends, media recording should stop. Right now, we'll continue recording even if the stream ends.

STR

1. Select detodos.opus and Setup
2. In console - run mediaRecorderList[0].start();
3. Hit play on both media controls
4. Wait for media file to finish playing

Expected

The media recorder should stop when recording ends.

Actual

The media recorder continues to record even when the stream ends.
(Reporter)

Updated

4 years ago
Blocks: 896935
(Reporter)

Updated

4 years ago
Blocks: 934818
(Reporter)

Updated

4 years ago
Duplicate of this bug: 951890
take it...I miss it.
Assignee: nobody → rlin
Could you give me the sample js script for me to test?
Flags: needinfo?(jsmith)
(Reporter)

Comment 4

4 years ago
STR

1. Go to http://mozilla.github.io/qa-testcase-data/webapi/mediarecorder/
2. Select setup with detodos.opus selected under setup opus stream for media recorder
3. Click play on media controls for input & output
4. Select start recording
5. Wait until the media finishes playing
Flags: needinfo?(jsmith)
(Reporter)

Comment 5

4 years ago
This no longer reproduces on trunk. Don't know what fixed it.
No longer blocks: 896935, 934818
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
I am experiencing this issue in the 2014/02/14 build.
Environmental Variables:
Device: Buri v1.3 Moz RIL
BuildID: 20140214004001
Gaia: 22e065f75193f569a78a8ec827b08e1ed520e1b2
Gecko: e3766683210c
Version: 28.0
Firmware Version: v1.2-device.cfg

The blob is not generated until 'Stop Recording' is pressed. Once the user stops recording, the blob appears, and the length of the blob is equal to the length of the source media file. This leads me to believe that the device stops recording at the end of the media event, but does not generate a blob until stop recording is pressed.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

4 years ago
Please see above comment which states trunk, not 1.3. This is not fixed on 1.3 & won't ever be fixed there.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
Component: Video/Audio → Video/Audio: Recording
You need to log in before you can comment on or make changes to this bug.