Historical Date and Time Calculations - new Date(1142146800000).getTimezoneOffset()

RESOLVED DUPLICATE of bug 1233809

Status

()

defect
RESOLVED DUPLICATE of bug 1233809
6 years ago
3 years ago

People

(Reporter: vic99999, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1612.2 Safari/537.36

Steps to reproduce:

set TimeZone to 
`new Date(1142146800000).getTimezoneOffset()`
should return 300
see http://blogs.msdn.com/b/ie/archive/2013/03/25/spring-forward-advancing-historical-date-and-time-calculations-on-the-web.aspx



Actual results:

IE 10, 11: 300
Chrome, Opera 12, Firefox: 240




Expected results:

300
Reporter

Comment 1

6 years ago
sorry, TimeZone should be "America/New_York" for the test case

Updated

6 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Assignee: general → nobody
Dup forward to bug 1233809
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233809
You need to log in before you can comment on or make changes to this bug.