Closed Bug 911695 Opened 8 years ago Closed 8 years ago

Reader mode toolbar icons are blurry

Categories

(Firefox for Android Graveyard :: Reader View, defect)

All
Android
defect
Not set
normal

Tracking

(firefox24 unaffected, firefox25 verified, firefox26 verified, firefox27 verified, fennec25+)

VERIFIED FIXED
Firefox 27
Tracking Status
firefox24 --- unaffected
firefox25 --- verified
firefox26 --- verified
firefox27 --- verified
fennec 25+ ---

People

(Reporter: pretzer, Assigned: lucasr)

References

Details

(Keywords: regression, reproducible)

Attachments

(2 files)

Attached image Screenshot of the issue
The icons on the reader mode toolbar and the anchor arrow graphic are blurry in current Nightly builds. This is a regression, they appear clearly in the current Release build.

Device: Samsung Galaxy S2, Android 4.1.2
tracking-fennec: --- → ?
The regression window is:

mozilla-central
good build: 16.07.2013 
bad build: 17.07.2013 
-pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5976b9c673f8&tochange=0888e29c83a3
The tinderbox inbound builds are missing since the issue is older than one month.
Assignee: nobody → lucasr.at.mozilla
tracking-fennec: ? → 25+
Keywords: reproducible
I wonder if the correct @media-screen queries are returning the right PNG's?
The semantics of the screen density values have changed in Firefox 25. This patch updates our media queries accordingly.
Attachment #813111 - Flags: review?(margaret.leibovic)
For the record, this was a regression from bug 803207.
Blocks: 803207
Attachment #813111 - Flags: review?(margaret.leibovic) → review+
Comment on attachment 813111 [details] [diff] [review]
Use correct dppx values for reader mode in HDPI and XHDPI devices

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 803207
User impact if declined: Blurry icons in Reader Mode's toolbar on hdpi/xhdpi devices
Testing completed (on m-c, etc.): Landed in m-c. No issues. 
Risk to taking this patch (and alternatives if risky): Very low risk. Just a couple of tweaks in Reader Mode's css.
String or IDL/UUID changes made by this patch: n/a
Attachment #813111 - Flags: approval-mozilla-beta?
Attachment #813111 - Flags: approval-mozilla-aurora?
Attachment #813111 - Flags: approval-mozilla-beta?
Attachment #813111 - Flags: approval-mozilla-beta+
Attachment #813111 - Flags: approval-mozilla-aurora?
Attachment #813111 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/174281a0f434
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Verified fixed on:
Build: Firefox for Android 25 Beta 6, Firefox for Android 26 Aurora (2013-10-08) and Firefox for Android 27 Nightly (2013-10-08) 
Device: Samsung Galaxy Nexus
OS: Android 4.1.1
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.