Closed Bug 911853 Opened 7 years ago Closed 7 years ago

OpenGL types should be explicit-size integer types

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: bjacob, Assigned: bjacob)

References

Details

Attachments

(1 file)

GLint is defined as an integer type of at least 32bit (and of course, in practice, exactly 32bit). So int32_t is a better match than int. In practice, it doesn't matter much, but we could eventually have a platform where int's are 64bit and there, we'd probably still want GLint to be 32bit.

Fixing this is also a prereq to discarding redundant WebGL typedefs, see dependent bug.
Attachment #798637 - Flags: review?(jgilbert)
Blocks: 911855
Attachment #798637 - Attachment is patch: true
Attachment #798637 - Flags: review?(jgilbert) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/104a75d724dd
Assignee: nobody → bjacob
Target Milestone: --- → mozilla26
Duplicate of this bug: 748073
You need to log in before you can comment on or make changes to this bug.