Closed Bug 911855 Opened 6 years ago Closed 6 years ago

Remove redundant WebGL integer typedefs

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26

People

(Reporter: bjacob, Assigned: bjacob)

References

Details

Attachments

(1 file)

WebGL's IDL defines several integer typedefs. Most of them are identical to their OpenGL counterparts. That redundancy has led to useless thinking while writing WebGL patches. Let's remove the types that are really redundant. A few types remain, as they are really different from their OpenGL counterparts. These are:
* WebGLboolean  (is bool, while OpenGL wants an integer type)
* WebGLsizeiptr and WebGLintptr (are always 64bit while OpenGL wants intptr_t).
Attachment #798639 - Flags: review?(jgilbert)
This depends on bug 911853 because per the Web IDL spec, the WebGL typedefs really want to be explicit-sized.
Depends on: 911853
Nice!!!
Comment on attachment 798639 [details] [diff] [review]
Remove redundant WebGL integer typedefs

Review of attachment 798639 [details] [diff] [review]:
-----------------------------------------------------------------

I did a quick job and my eyes still ended up numb.
Attachment #798639 - Flags: review?(jgilbert) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/f40f6fb9d98c
Assignee: nobody → bjacob
Target Milestone: --- → mozilla26
https://hg.mozilla.org/mozilla-central/rev/f40f6fb9d98c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 748076
You need to log in before you can comment on or make changes to this bug.