EarlyBlue theme: Password prompt not asking

RESOLVED INCOMPLETE

Status

SeaMonkey
General
RESOLVED INCOMPLETE
5 years ago
3 years ago

People

(Reporter: George W, Unassigned, NeedInfo)

Tracking

SeaMonkey 2.20 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 SeaMonkey/2.20 (Beta/Release)
Build ID: 2013080300

Steps to reproduce:

Seamonkey stopped prompting me to add or change passwords at websites. However, It would continue to issue passwords previously saved. I have no problem with email passwords. Even if I rebuild an email account, it will ask for the password and give me an option to save it. It then handles that email password just fine. Websites don't work.

I reinstalled SM. No solution.
I uninstalled Seamonkey and reinstalled. Still no solution.
I uninstalled, erased the entire mozilla directory and reinstalled. No solution.

I got so frustrated I formatted the HD, reinstalled Open Suse 12.3_64, installed Seamonkey form the Suse/Mozilla repository, updated everything. Still no prompt to save passwords.

I created a 2nd identity in Seamonkey. Still won't prompt.

One other peculiar problem that might be a clue:
On every email account, Junk Settings allow two check boxes:
Do not automatically mark mail as junk if sender is in 
[ ] Collected Addresses 
[ ] Personal Address Book
I can't check either box. It just won't accept the mouse click.


Actual results:

No matter what I do, I can't get Seamonkey to ask me if I want to save a password associated with websites. (email passwords are not a problem).


Expected results:

Prompt me.
(Reporter)

Comment 1

5 years ago
I figured it out. Its the EarlyBlue theme. Change the theme and all the problems disappear. This theme says its good for Seamonkey 2.20. It is not good. I have run the theme for several years, fully updated, and Seamonkey never objected on any upgrade.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 2

5 years ago
> I figured it out. Its the EarlyBlue theme
I think this is just a coincidence. More likely bugs:
Bug 886990 - Passwords not saving or autofilling
Bug 908141 - Password manager does not work on script-generated forms
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23a1 ID:20130829003001 c-c:2e8458f26a91 m-c:aebdc69b02e5

I've been using EarlyBlue for years (since the Toolkit Transition or maybe even earlier) without ever getting any password problem. But I'm using bleeding-edge versions of both SeaMonkey ("comm-central-trunk" builds from ftp.mozilla.org) and EarlyBlue (the "master" branch from http://git-public.kairo.at/themes.git, then run "maketheme EarlyBlue" in the top directory of the git clone to generate an .xpi).
Oops: it's ./maketheme EarlyBlue (the ./ is important: it allows finding the executable outside the $PATH).

Comment 5

3 years ago
@Reporter: Still a problem for you?
Flags: needinfo?(georgewest)
Summary: Password prompt not asking → EarlyBlue theme: Password prompt not asking

Comment 6

3 years ago
Neither password problem nor junk filter checkbox problem are reproducible  with DE SeaMonkey 2.35(γ)  (Windows NT 6.1; WOW64; rv:38.0 nightly by Adrian Kalla)  Gecko/20100101 Build 20150616034436 (Classic Theme) on German WIN7 64bit

Comment 7

3 years ago
Not reproducible -- I did some tests with 2.38 and Early Blue. No response, so I close this one for now.

@Reporter: Please feel free to reopen this Bug if you still can reproduce the problem with a current SeaMonkey version and a current OS and if you can contribute a step by step instruction due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>  (containing every key press and every mouse click) how to reproduce the problem reliably.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.