[B2G][Helix][camera][ouyangming]The modify time of the file created by camera App is error

RESOLVED DUPLICATE of bug 851680

Status

Firefox OS
Gaia::Camera
P2
blocker
RESOLVED DUPLICATE of bug 851680
5 years ago
5 years ago

People

(Reporter: lecky, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 798717 [details]
time-before-test.png

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

1. Make sure the time in settings is correct. Please refer the attached file(time-before-test.png)
2. Open the camera App, and take a photo, it will create the file named IMG_0001.jpg automatic.
3. Connect the device to the PC with the USB, (The device will use to be a large storage device),and open the path(like j:\DCIM\100MZLLA) which including the file IMG_0001.jpg.
4. Check the modify time of the IMG_0001.jpg on PC. Please refer the attched file(time-after-test.png).

My build information as following:
gaia commit id is: c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14
gecko commit id is:170f9e477571127cd40997fa2abe262ed43f0e4d




Actual results:

1. The modify time of the IMG_0001.jpg is error. Compare the time on the attached pictures, and will find the problem. When take the photo, the true time is 2:42 PM, But see in PC the time is 6:40. It is incorrect.


Expected results:

1. The modify time of the IMG_0001.jpg see in PC is close to the true time.
(Reporter)

Comment 1

5 years ago
Created attachment 798718 [details]
time-after-test.PNG
(Reporter)

Updated

5 years ago
Severity: normal → blocker
blocking-b2g: --- → hd?
Priority: -- → P2
Hi lecky, could this be bug 851680?
Flags: needinfo?(lecky.wanglei)
(Reporter)

Comment 3

5 years ago
Yes, it looks the same. Does this issue can be fixed on V1.1 or V1.2?
Flags: needinfo?(lecky.wanglei)
I don't believe this is targeted to either v1.1 or 1.2, but feel free to ping people in the original bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851680
(Reporter)

Comment 5

5 years ago
Hi Beatriz Rodriguez,

This issue would not solved on V1.1HD, Do you accept it?

Thanks.
Flags: needinfo?(brg)
yes, we accept current implementation. And we are happy to see that in bug 851680 can be consider as a new feature in the priorization of the work.
Flags: needinfo?(brg)

Updated

5 years ago
blocking-b2g: hd? → -
You need to log in before you can comment on or make changes to this bug.