unresolved symbol when linking xul.dll

RESOLVED DUPLICATE of bug 915102

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 915102
5 years ago
4 months ago

People

(Reporter: zhoubcfan@163.com, Unassigned)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130901174911

Steps to reproduce:

win8.1 64bit and vs3013preview, buiding the trunk source. when linking xul.dll, the error appear.

PositionErrorBinding.obj : error LNK2019: unresolved symbol "public: virtual en
um tag_nsresult __stdcall mozilla::dom::PositionError::GetMessage(class nsAStrin
g_internal &)" (?GetMessage@PositionError@dom@mozilla@@UAG?AW4tag_nsresult@@AAVn
sAString_internal@@@Z),the symbol is referenced in function "bool __cdecl mozilla::dom::PositionErrorBi
nding::get_message(struct JSContext *,class JS::Handle<class JSObject *>,class m
ozilla::dom::PositionError *,class JSJitGetterCallArgs)" (?get_message@PositionE
rrorBinding@dom@mozilla@@YA_NPAUJSContext@@V?$Handle@PAVJSObject@@@JS@@PAVPositi
onError@23@VJSJitGetterCallArgs@@@Z)
(Reporter)

Updated

5 years ago
Hardware: x86_64 → All

Comment 1

5 years ago
Has anyone else tried building with the VS 2013 preview?
Component: Geolocation → Build Config
(In reply to Josh Matthews [:jdm] from comment #1)
> Has anyone else tried building with the VS 2013 preview?

VS2013 preview has several bugs to build Firefox.  About compiler issue, I reported to MS, then they say "fixed by RTM".  But I don't see this build error.
(Reporter)

Comment 3

5 years ago
the problem only appear in recent days(last fine build is based on f2088f137851). I build with xpsupport, -opt:ref with debug symbol disabled and other local changes.
(Reporter)

Comment 4

5 years ago
put the #include "PCOMContentPermissionRequestChild.h" back into nsGeolocation.h, then the error is gone

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915102

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.