When proxy configuration set to "Use system proxy settings", firefox not use https_proxy and ftp_proxy environment variables under gnu/linux

RESOLVED INVALID

Status

()

Core
Networking
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Zhou Wei, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E; BOIE9;ENUS)

Steps to reproduce:

1. Set http_proxy, ftp_proxy and https_proxy system proxy environment variables in GNU/Linux and make sure they are all exported and can be used system widely.

2. Make sure GSettings/GConf do not provide proxy settings. This is make sure firefox to get proxy settings from system proxy environment variables.

3. Start Firefox in GNU/Linux, set Firefox proxy setting configuration to be "Use system proxy settings".

3. Use firefox to access http, https and ftp sites. Check the access logs in the corresponding proxy site.


Actual results:

1. For accessing http site, firefox will use the http_proxy environment variable.
2. Accessing https will not use https_proxy and Accessing ftp site will not use ftp_proxy.


Expected results:

1. Both http/https/ftp should use their corresponding _proxy environment variable.
(Reporter)

Updated

4 years ago
Component: Untriaged → Networking
OS: Windows 7 → Linux
Product: Firefox → Core
(Reporter)

Comment 1

4 years ago
Created attachment 798749 [details] [diff] [review]
Patch for bug 911919 review

Comment 2

4 years ago
Comment on attachment 798749 [details] [diff] [review]
Patch for bug 911919 review

Thanks for the patch, Zhou Wei! I've tagged Patrick to review this, since all code changes require review (see https://developer.mozilla.org/en-US/docs/Developer_Guide/How_to_Submit_a_Patch#Getting_the_patch_reviewed).
Attachment #798749 - Flags: review?(mcmanus)
Comment on attachment 798749 [details] [diff] [review]
Patch for bug 911919 review

Review of attachment 798749 [details] [diff] [review]:
-----------------------------------------------------------------

First, thanks for the patch!

maybe I misunderstand this patch - but as I read it what it says is that https://www.example.com/ will now be allowed for the value of a SCHEME_proxy variable. But we don't implement proxying over https (we might soon, but right now we don't). However a value of http://www.example.com for the var https_proxy looks like it would work as expected (i.e. proxy https traffic through an http proxy using CONNECT tunnels) - and that seems to be the case you are interested in.

Do I misunderstand?
Attachment #798749 - Flags: review?(mcmanus) → review-
(Reporter)

Comment 4

4 years ago
Thanks Josh and Patrick for your review !

Do you mean that https://www.example.com is not allowed to be set in SCHEME_proxy ? But we have this kind of environment for doing test. :)
If firefox tries to load https://www.example.com and https_proxy is set to http://myproxy I know what happens - a plaintext http connection is made to myproxy and a CONNECT tunnel is established through it to www.example.com:443 preserving end to end ssl.

if you set https_proxy to https://myproxy (as your patch allows) what do you think should happen? Have you tested it?

I think we should support that (especially with spdy), but I'm pretty confident we don't yet.
(Reporter)

Comment 6

4 years ago
With my patch, it seems that the firefox will use the https_proxy and access the https site in our test environment correctly which has the same effect like manually set https proxy in firefox/network/proxy setting tab.

I get your idea that: SCHEMA_proxy which means using SCHEMA protocol to access the proxy. But how if the proxy just simply forward the request to the web server?  For https_proxy, if there is any possible that:
firefox using SSL to proxy, proxy do a transfer and then proxy use another SSL tunnel to web site? Or any possible that in https, firefox ignore the https::// in the https_proxy setting and just use http to connect to the proxy ?

We test https_proxy and ftp_proxy set to like http://myproxy works in firefox. We do a compare to Microsoft IE (just do a compare test and not going to say which one is better :D).  IE use ftp connect to ftp_proxy using ftp://myftpsite and the proxy ftp to the real ftp site. Also Linux command wget seems to do the same thing like IE.
We proxy http, https, and ftp over http right now..

I've lost track of what use case you are trying to accomplish here. Can you provide a clear description and how your patch achieves that?

The way I read your patch it says "allow proxying over ftp or https" - but it doesn't implement those things.
(Reporter)

Comment 8

4 years ago
OK. Got it. So seems that the patch is not useful if firefox proxy http, https, and ftp over http now. Any way, thank a lot for your feedback.
no problem. If you'd like t implement proxying over https I'd take that patch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.