[WAP push] When SI is expired after received it, there is no indicator or wording shows that it's expired.

RESOLVED DUPLICATE of bug 911934

Status

RESOLVED DUPLICATE of bug 911934
5 years ago
5 years ago

People

(Reporter: echu, Assigned: gsvelto)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [FT:RIL, burirun2])

Attachments

(2 attachments)

573.63 KB, text/plain
Details
351.73 KB, application/pdf
Details
(Reporter)

Description

5 years ago
Created attachment 798765 [details]
17:24.

When SI is expired after received it, there is no indicator or wording shows that it's expired. Please refer to UX doc.

* Build Number                
Gaia:     9fb5802df60a9081846d704def01df814ed8fbd4
Gecko:    http://hg.mozilla.org/mozilla-central/rev/b6c29e434519
BuildID   20130901040215
Version   26.0a1

* Reproduce Steps
1. Send SI with SI Expires value 2013-09-05-T03:33:33Z from NowSMS to DUT. (later than the date of the test)
2. After receive the message, change device data and time later than the expire date.
3. open the message.

* Expected Result
"This message was expired" in the content of the message and URL cannot be tapped.

* Actual Result
No expired words. 

* Occurrence rate
100%.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → koi?
(Reporter)

Comment 1

5 years ago
Created attachment 798766 [details]
Wap_Push_Message_0.2.pdf
(Reporter)

Updated

5 years ago
Blocks: 891248

Updated

5 years ago
blocking-b2g: koi? → koi+

Updated

5 years ago
Assignee: nobody → gsvelto
(Reporter)

Updated

5 years ago
Whiteboard: [FT:RIL]
(Reporter)

Updated

5 years ago
Whiteboard: [FT:RIL] → [FT:RIL, burirun2]
(Assignee)

Comment 2

5 years ago
This is being addressed as part of bug 911934. The WIP patch on that bug implements the correct behavior according to the spec.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911934
You need to log in before you can comment on or make changes to this bug.