[Bluetooth][User Story] bluedroid stack GAP feature (Pair/Discover/SetVisible/Rename/EnableDisable)

RESOLVED FIXED in Firefox 28

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: shawnjohnjr, Assigned: shawnjohnjr)

Tracking

unspecified
1.3 Sprint 4 - 11/8
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox28 fixed)

Details

bluedroid stack: Pair/Scan/Set name/Discoverable etc basic feature
Blocks: 876583
Summary: [meta] bluedroid stack GAP feature (Pair/Discover) → [Bluetooth][User Story] bluedroid stack GAP feature (Pair/Discover/SetVisible/Rename/EnableDisable)
Target Milestone: --- → 1.3 Sprint 3 - 10/25
Assignee: nobody → shuang
blocking-b2g: --- → 1.3+
Target Milestone: 1.3 Sprint 3 - 10/25 → 1.3 Sprint 4 - 11/8
All blocking bugs have been resolved. Close as resolved fixed.

Thanks for everyone, especially Shawn. :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Flags: in-moztrap?(wachen)
Hi, I will be creating test cases (if needed).
For bluedroid, we'd like to test on PTS.
Can you create one PTS profile for bluedroid GAP and create another PTS profile for bluez GAP? (Or, will the profile be the same?) We need to verify if the behavior would be the same in bluez and bluedroid.
Flags: needinfo?(echou)
Duplicate of this bug: 909252
(In reply to Walter Chen[:ypwalter][:wachen] from comment #2)
> Hi, I will be creating test cases (if needed).
> For bluedroid, we'd like to test on PTS.
> Can you create one PTS profile for bluedroid GAP and create another PTS
> profile for bluez GAP? (Or, will the profile be the same?) We need to verify
> if the behavior would be the same in bluez and bluedroid.

Sure we will, but as we discussed before, I think 'aurora' is the best branch for PTS testing since it's more stable and at least feature complete. Therefore I would say that we should start testing from your test cases.
Flags: needinfo?(echou)
Ok then, we will run PTS whenever it goes to aurora and only doing some test cases modification and UI testing as for now.
Basic testing is done.
https://bugzilla.mozilla.org/show_bug.cgi?id=937973
This bug opens accordingly. And the verification pends on bug 937973 now.

Also, for test cases now: 
8576,8578,8569,6935 modified
8569,6935,3518,3575,3520,3523,2479,1397 tagged
6751-6754 name modified
Related test cases are marked as "gap" tag, and you should be able to find test cases by "gap" tag in moztrap.

I will do the test cases creation soon.
Depends on: 937973
Cases for v1.2 also tagged accordingly to the list above for reference.
Just merged original bluetooth settings test cases from "Settings" suite. Trying to modify the bad test cases created by others and reduce the duplicated tests cases. We will clean the test cases a little bit more to make sure that QAnalyst can do their job for us.
Test cases 10746&10747 added
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
It's done testing
Flags: in-moztrap?(wachen) → in-moztrap+
status-firefox28: --- → fixed
You need to log in before you can comment on or make changes to this bug.