compose_html setting interface broken

RESOLVED WORKSFORME

Status

Thunderbird
Preferences
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: alex, Unassigned)

Tracking

17 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

Situation: I want to disable composing E-Mails as HTML
- Go to Account Preferences, email@somewhere, Composition & Adressing to uncheck "Compose messages in HTML format"


Actual results:

- Checkbox was not checked
- The HTML Editor were used
- Checking the box, saving preferences, unchecking the box, saving preferences fixed the issue.


Expected results:

- The checkbox should be consistent with the actual setting.

Checking about:config, mail.identity.id1.compose_html was type "string". Now its type boolean, and it seems to work.

Comment 1

4 years ago
(In reply to Alexander Schier from comment #1)
> Steps to reproduce:
> 
> Situation: I want to disable composing E-Mails as HTML
> - Go to Account Preferences, email@somewhere, Composition & Adressing to
> uncheck "Compose messages in HTML format"
> 
> Expected results:
> 
> - The checkbox should be consistent with the actual setting.
> 

Tested on trunk build and it is working as expected.

> Checking about:config, mail.identity.id1.compose_html was type "string". Now
> its type boolean, and it seems to work.

Is it working now, Alexander? If so, might you consider close as INVALID this bug? Thank you.
(Reporter)

Comment 2

4 years ago
It works for me, but i doubt the bug is closed, if there is no bugfix for that in trunk.
Not sure, if it should be closed. On the other hand, i cannot give a way to reproduce at the moment, and it may be, that this is an issue when migrating from one version to another, and fixed for setting up accounts in the current version.

Comment 3

3 years ago
(In reply to Alexander Schier from comment #2)
> It works for me, but i doubt the bug is closed, if there is no bugfix for
> that in trunk.
> Not sure, if it should be closed. On the other hand, i cannot give a way to
> reproduce at the moment, and it may be, that this is an issue when migrating
> from one version to another, and fixed for setting up accounts in the
> current version.

If you can't reproduce, then you want to close the bug as WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

3 years ago
I am not sure, if its only "workaround works for me".

I am not sure, what caused the problem, but i doubt its actually closed, but without an easy way to reproduce it, its hard to test as well. My profile had this setting as string, with a boolean setting it works. If somebody knows the source for this, maybe he can find what's the cause, otherwise it may be closed here until its a problem for more people.
You need to log in before you can comment on or make changes to this bug.