DNS: illegal fqdn (> max characters per label) errors slowly

VERIFIED WORKSFORME

Status

()

Core
Networking
P4
enhancement
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: benc, Assigned: gordon)

Tracking

Trunk
Future
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
MacOS: 2001-07-17-03-0.9.2, Commercial RTM candidate build

Testing:

Connecting to two domains:
123456789012345678901234567890123456789012345678901234567890123.com
1234567890123456789012345678901234567890123456789012345678901234.com

The first has a 63 character label, which is the specified limit.
The second has a 64 character label, which exceeds the limit.

Clicking on a link with the first fqdn returns a DNS error.
"Alert
www.<label>.com could not be found. Please try again."

Clicking on a link with the second fqdn causes status bar and throbber to run w/
"Resolving host <label>.com" and then stop w/o error.

Expected behavior:
We should probably trap illegal DNS entries, esp since handing off bad data to
the DNS and OS layers could be unpredicable.

Notes:
nslookup barfs when it is tested.

# nslookup
Default Server:  dns1-sf.snfc21.pacbell.net
Address:  206.13.28.12

> 1234567890123456789012345678901234567890123456789012345678901234.com
Server:  dns1-sf.snfc21.pacbell.net
Address:  206.13.28.12

*** dns1-sf.snfc21.pacbell.net can't find 12345678901234567890123456789012345678
90123456789012345678901234.com: Unspecified error
> 123456789012345678901234567890123456789012345678901234567890123.com
Server:  dns1-sf.snfc21.pacbell.net
Address:  206.13.28.12

*** dns1-sf.snfc21.pacbell.net can't find 12345678901234567890123456789012345678
9012345678901234567890123.com: Non-existent host/domain
(Reporter)

Comment 1

17 years ago
Actually, the 64 character label does return an error for www.<label>.com after
about 30 seconds.
(Reporter)

Comment 2

17 years ago
Win32 (Win 98 returns the error immediately).

MacOS comes back after a long delay, but works.

I'm pondering marking this an RFE.

Would anyone ever care we send bad DNS queries?

Comment 3

17 years ago
2 gordon.
Assignee: neeti → gordon
(Assignee)

Updated

17 years ago
Severity: minor → enhancement
Status: NEW → ASSIGNED
Priority: -- → P4
Target Milestone: --- → Future
(Reporter)

Comment 4

16 years ago
RESOLVED: WFM, Mac OS 9, RC1.
The abnormally long error message in MacOS 9 seems to be gone now.

I"ve clarified the subject of the bug to reflect the original reason I filed
this bug (the Mac OS 9 only aspects).

I've filed a new RFE about doing a check for illegal charcters in a DNS FQDN
(bug 140379).

--
+verifyme - if someone can confirm this works okay for them in Mac OS 9, that
would be great.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: verifyme
Resolution: --- → WORKSFORME
Summary: DNS: illegal fqdn (> max characters per label) errors wrong → DNS: illegal fqdn (> max characters per label) errors slowly
(Reporter)

Comment 5

14 years ago
V: CFM, RIP.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.