Closed Bug 912028 Opened 6 years ago Closed 6 years ago

[Keyboard] [New IME] Background is visible when keyboard pop in animation plays

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: janjongboom, Assigned: janjongboom)

Details

(Whiteboard: [ft:system-platform])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
rudyl
: review+
Details | Review
The client app gets new height immediately instead of when the keyboard pop in animation is ended causing the background image to be visible.

Easy to be seen in FF desktop but also reproducible on device.

Newly introduced with the new IME changes.
blocking-b2g: --- → koi?
Whiteboard: [ft:system-platform]
Need to be fixed.
Assignee: nobody → rlu
blocking-b2g: koi? → koi+
Assignee: rlu → janjongboom
Attached file Patch
The current code tried to address this issue already but made two wrong assumptions:

If hide was not in classList of keyboard the height would be updated directly. It didn't take into account that the open transition might be happening at that time and the height would be incorrect.
Listens to first transform event that comes in, and that is the visibility transition; not the transform (which we should be waiting for).
(CSS) We ease on visibility but that doesn't have an ease. Should do it on opacity.
So those are the issues addressed. I've written tests around it because it felt quite fragile when touching it; and it helps with quickly testing my assumptions as well :-)
Attachment #811057 - Flags: review?(rlu)
Attachment #811057 - Flags: review?(rlu) → review?(dflanagan)
Attachment mime type: text/plain → text/x-github-pull-request
Comment on attachment 811057 [details] [review]
Patch

[Steal the review]

Looks good to me, except some minor comments on the test cases.

Jan,

Thanks for the good work and even adding the test cases.
Attachment #811057 - Flags: review?(dflanagan) → review+
Landed in https://github.com/mozilla-b2g/gaia/commit/ea8548e802138bb1830f6c8991d4beb461b6207c

Do we need to do uplift ourselves?
Flags: needinfo?(rlu)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Jan Jongboom [:janjongboom] from comment #4)
> Landed in
> https://github.com/mozilla-b2g/gaia/commit/
> ea8548e802138bb1830f6c8991d4beb461b6207c
> 
> Do we need to do uplift ourselves?

I guess not.
koi+ and setting status-b2g-v1.2 to "affected" would make this uplifted auto-magically. :)
Flags: needinfo?(rlu)
Uplifted ea8548e802138bb1830f6c8991d4beb461b6207c to:
v1.2: 8baf96d506e84af2e3ab0832062a7c81ba36df37
You need to log in before you can comment on or make changes to this bug.