ReferenceError in XHR handling

RESOLVED FIXED

Status

L20n
HTML Bindings
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mik01aj, Assigned: gandalf)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1588.0 Safari/537.36

Steps to reproduce:

I don't know. Perhaps I pressed stop in my browser.

But the issue is, that there is a piece of code like this:

xhr.addEventListener('abort', function(e) {
   callback(ex);
 });


Actual results:

It thrown a ReferenceError


Expected results:

I think that there should be "ex" instead of "e". Looks like a simple bug to fix.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

5 years ago
Created attachment 799607 [details] [diff] [review]
912053.patch

great catch! Thank you!

Attaching a patch proposal. Michal, can you take a look?
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
Attachment #799607 - Flags: review?(m.goleb+mozilla)
(In reply to Zbigniew Braniecki [:gandalf] from comment #1)
> Created attachment 799607 [details] [diff] [review]
> 912053.patch
> 
> great catch! Thank you!
> 
> Attaching a patch proposal. Michal, can you take a look?

Should be good. :)
Comment on attachment 799607 [details] [diff] [review]
912053.patch

Review of attachment 799607 [details] [diff] [review]:
-----------------------------------------------------------------

Seems fine for me. Thanks!
Sorry for the comment mess, I don't know how to mark an attachment as reviewed here (I haven't contributed a lot of patches/etc. on Bugzilla so far).
Attachment #799607 - Flags: review?(m.goleb+mozilla) → review+
(Assignee)

Comment 5

5 years ago
https://github.com/l20n/l20n.js/commit/85c29d6333a5cad4f2130dae33d37ebcebe566f7

thanks guys!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.