PDF Viewer crashes the browser when loading an image-heavy PDF

RESOLVED WORKSFORME

Status

()

Firefox
PDF Viewer
--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Matthew Bowker, Unassigned)

Tracking

26 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-f-need-info])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 798877 [details]
OSX Crash Report

I'm attempting to open the PDF version of http://publ.com/ZQ6Fyqt (It's at the download button at the bottom).  The PDF file loads about half-way then the browser crashes.  

I've attached the OSX error report, and my crash report is located at https://crash-stats.mozilla.com/report/index/73c56dbe-e72b-4b03-9d95-8a77b2130820

Comment 1

5 years ago
It doesn't crash FF on Windows. Surely Mac only and related to bug 910347.

Comment 2

5 years ago
Created attachment 801553 [details]
Guys Guide to Marrying Well.pdf

Updated

5 years ago
Depends on: 910347
Bug 910347 no longer happens in recent trunk (aka mozilla-central) nightlies.  The same may be true for this bug.

Please test with today's mozilla-central nightly (ftp://ftp.mozilla.org/pub/firefox/nightly/2013-09-09-03-02-04-mozilla-central/firefox-26.0a1.en-US.mac.dmg).

Updated

5 years ago
Flags: needinfo?(matthewrbowker)

Updated

5 years ago
Whiteboard: [pdfjs-f-need-info]
(Reporter)

Comment 4

5 years ago
Now works for me, latest nightly appears to have fixed it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(matthewrbowker)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.