Problem compile SeaMonkey to 64 Bit error C3861: '__readfsdword': identifier not found

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: vlposta, Unassigned)

Tracking

SeaMonkey 2.23 Branch
x86_64
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 799133 [details]
readfsdword_not_found.gif

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23a1 (Beta/Release)
Build ID: 20130903193404

Steps to reproduce:

To 32 Bit i compile build 20130903193404 successfully, but to 64 Bit on Windows 8 AMD64 canot compile it with this .mozconfig

ac_add_options --enable-application=suite
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-sm-release
mk_add_options MOZ_MAKE_FLAGS="-j4"
ac_add_options --disable-debug
ac_add_options --disable-debug-symbols
ac_add_options --disable-tests
ac_add_options --disable-ipdl-tests
#602 = Windows 8 
ac_add_options --with-windows-version=602
mk_add_options MOZ_OPTIMIZE_LDFLAGS=-MACHINE:X64
ac_add_options --enable-64bit
ac_add_options --target=x86_64-pc-mingw32
ac_add_options --host=x86_64-pc-mingw32
ac_add_options --enable-optimize='-O2 -GR- -GS- -favor:AMD64 -arch:AVX



Actual results:

Poison.cpp
C:\Program Files (x86)\Windows Kits\8.0\include\um\winnt.h(18863) : error C3861: '__readfsdword': identifier not found

(If include "intrin.h" canot build due to link 32+64 bit *.obj)


Expected results:

Compile latest SM 2.23a1 in 64bit for my Windows 8, AMD64
- 32 bit version 2.23a1 use only 4GB of my 8GB RAM and if alocate more,
then not use page file, but crashed.

In 64 Bit i have seamonkey-2.20-x64-20130811 only,
this build not crashed, but i try testing latest build in 64bit ...
You use 32-bit compiler.  You should use start-msvc*-x64.bat in MozillaBuild.
Also, if using express version, see bug 903945
(Reporter)

Comment 3

5 years ago
Thank You - to many warnings (type conversations), but susscefully compiled
and now i testing build 20130904113630 compiled and omptimized for my AMD64 VIZ (Trinity) ...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.