Launching embedding app from /bin results null event queue assertion. Can't launch or debug.

VERIFIED DUPLICATE of bug 92798

Status

()

Core
Embedding: APIs
VERIFIED DUPLICATE of bug 92798
17 years ago
17 years ago

People

(Reporter: David Epstein, Assigned: Adam Lock)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
not sure who should look at this bug. It happened in both 7/16 and 7/17
embedding builds. Saw this assertion for mfcEmbed, winEmbed, and testEmbed.
1. Download latest source.
2. cd to embedding app dir like /mozilla/embedding/qa/testembed.
3. build the app. nmake -f makefile.win
4. cd /mozilla/dist/WIN32_D.OBJ/bin
5. run the app from the dos shell (e.g. testembed.exe).
Result: Get assertion: "event queue is null: 'mEventQueue', file
/mozilla/htmlparser/src/nsParser.cpp line 366. I press Retry to debug, but
nothing happens. Ignore keeps returning the assertion. Pressing abort quits the
app after getting another assert: "nsDOMEvent not thread-safe": 'owningThread ==
NS_CurrentThread()', file /mozilla/xpcom/base/nsDebug.cpp line 528.

The workaround is to remove the component.reg file from /bin dir. Then relaunch.
(Reporter)

Comment 1

17 years ago
marking this as a dup of 92798

*** This bug has been marked as a duplicate of 92798 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
dupe of 92798
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.