Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 91229 - message list display changes when i click on a message that has a long subject header
: message list display changes when i click on a message that has a long subjec...
Status: VERIFIED DUPLICATE of bug 91662
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: (not reading, please use instead)
: esther
Depends on:
  Show dependency treegraph
Reported: 2001-07-17 18:47 PDT by Ka Otep
Modified: 2004-11-22 17:25 PST (History)
0 users
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description Ka Otep 2001-07-17 18:47:04 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

In mailnews, when i click on a message that has a very long subject header, the
message display list changes. The header columns expands and the rightmost
columns can't be viewed anymore.  This happens when the long subject header has
no spaces.  

For example:

If the long message subject looks like this

  this is a verry long long long ... long message 

Note: the message subject is about 250+ chars long.

the display is ok but if the message looks like this..

this is a veryyy longggg...ngggggggggggggggggggggggg message..

Note: longggg is about 120+ chars.

The message list display changes, the columns expand and the rightmost columns
disappear as what would happen if you resize a window to a small one and the
scroll bars appear.. this time there are no scroll bars because the message list
display does not have one.

Reproducible: Always
Steps to Reproduce:
1. compose a mail message
2. enter a long message subject with a word that is about 120+ chars long or
longer if the display size is big.
3. try to make the mailnews screen size small so it will be easier to reproduce.
4. send the mail to yourself.
5. retrieve the mail and select the new mail message

Actual Results:  the screen flickers for a while (like when you click on another
folder) the columns expands and the rightmost columns disappear from sight.

Expected Results:  no flickering and the column sizes shouldnt have changed.
Comment 1 Michael Hendy (Hendikins) 2001-07-18 10:19:16 PDT
WFM, 2001071604/Windows NT

Reporter: Have you tried with a recent nightly build?
Comment 2 Michael Hendy (Hendikins) 2001-07-18 10:20:37 PDT
scratch that, I've managed to reproduce it....

Marking new
Comment 3 laurel 2001-07-20 13:47:21 PDT

*** This bug has been marked as a duplicate of 91662 ***
Comment 4 laurel 2001-07-20 13:47:54 PDT
Marking verified as a duplicate.

Note You need to log in before you can comment on or make changes to this bug.