Closed Bug 912327 Opened 7 years ago Closed 7 years ago

bug904743 cause rebuild error when disable debug symbols

Categories

(Firefox Build System :: General, defect)

All
Windows 8
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 914935

People

(Reporter: c, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130901174911

Steps to reproduce:

win8.1 vs2013preview MozillaBuild1.8 building the trunk. tons of message like the ones below appear. It seems that it's every source file.  
Does anyone know what the reason is? Did I do something wrong.  

No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginBackgr
oundDestroyer.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj
-12/ipc/ipdl/PPluginBackgroundDestroyer.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginBackgr
oundDestroyerChild.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/centra
l/obj-12/ipc/ipdl/PPluginBackgroundDestroyerChild.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginBackgr
oundDestroyerParent.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/centr
al/obj-12/ipc/ipdl/PPluginBackgroundDestroyerParent.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginIdenti
fier.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/ipc/i
pdl/PPluginIdentifier.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginIdenti
fierChild.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/
ipc/ipdl/PPluginIdentifierChild.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginIdenti
fierParent.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12
/ipc/ipdl/PPluginIdentifierParent.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginInstan
ce.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/ipc/ipd
l/PPluginInstance.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginInstan
ceChild.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/ip
c/ipdl/PPluginInstanceChild.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginInstan
ceParent.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/i
pc/ipdl/PPluginInstanceParent.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginModule
.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/ipc/ipdl/
PPluginModule.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginModule
Child.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/ipc/
ipdl/PPluginModuleChild.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginModule
Parent.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/ipc
/ipdl/PPluginModuleParent.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginScript
ableObject.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12
/ipc/ipdl/PPluginScriptableObject.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginScript
ableObjectChild.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/o
bj-12/ipc/ipdl/PPluginScriptableObjectChild.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginScript
ableObjectParent.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/
obj-12/ipc/ipdl/PPluginScriptableObjectParent.cpp:']
No rule to make target 'd:/develop/mozilla/central/obj-12/ipc/ipdl/PPluginStream
.cpp:' needed by ['<command-line>', 'd:/develop/mozilla/central/obj-12/ipc/ipdl/
PPluginStream.cpp:']
Hardware: x86_64 → All
the build can continue, though it is very slow and may run into memoryerror.
it only show up in rebuild. the files will be rebuilt though nothing change.
It's caused by --disable-debug-symbols(more accurate, the -Zi). But how is it related?
Blocks: 904743
OS: Windows NT → Windows 8
Summary: no rule to make target every source file → bug904743 cause rebuild error when disable debug symbols
Is this fixed by the patch in bug 914935?
Flags: needinfo?(zhoubcfan)
yes.
Flags: needinfo?(zhoubcfan)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 914935
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.