Closed Bug 912347 Opened 6 years ago Closed 6 years ago

stop showing the protocolHandlerRegistered door hanger.

Categories

(Firefox :: File Handling, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 26

People

(Reporter: dougt, Assigned: dougt)

References

Details

Attachments

(2 files)

Every time a webapp re-registers a protocol handler that is already registered, there is an info bar that displays:

%S has already been added as an application for %S links.

I am not sure why we do this, but it is pretty annoying.  Re-registering should be silent.
Summary: stop showing the → stop showing the protocolHandlerRegistered door hanger.
myk, do you mind if I remove this?
I don't mind!  And I agree.  This message is particularly confusing because it appears *before* the user is prompted to approve the registration; so it can easily come out of the blue, with no context to explain why it appeared:

  https://github.com/mozilla/mozilla-central/blob/f194714a1daafa4fe4ba0a211cf63e9e21f319e9/browser/components/feeds/src/WebContentConverter.js#L412-L416

And nothing in the spec requires or even suggests such a message:

  http://www.whatwg.org/specs/web-apps/current-work/#custom-handlers

However, I'm neither the owner nor a peer of the module in question (Firefox).  Let's see what Gavin thinks.
Flags: needinfo?(gavin.sharp)
no objection!
Flags: needinfo?(gavin.sharp)
Comment on attachment 800813 [details] [diff] [review]
bug_912347_prevent_already_registered_protocol_handler_info_bar

Review of attachment 800813 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/feeds/src/WebContentConverter.js
@@ +412,5 @@
>        // XXX this should be a "security exception" according to spec
>        throw("Not allowed to register a protocol handler for " + aProtocol);
>      }
>  
> +    var buttons;

I should remove this.
Duplicate of this bug: 913991
review ping?
Comment on attachment 800813 [details] [diff] [review]
bug_912347_prevent_already_registered_protocol_handler_info_bar

over to jaws -- his queue looks empty.
Attachment #800813 - Flags: review?(gavin.sharp) → review?(jaws)
Comment on attachment 800813 [details] [diff] [review]
bug_912347_prevent_already_registered_protocol_handler_info_bar

Review of attachment 800813 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/feeds/src/WebContentConverter.js
@@ +420,4 @@
>  
> +    var notificationIcon = uri.prePath + "/favicon.ico";
> +    var notificationValue = "Protocol Registration: " + aProtocol;
> +    var addButton = {

Remove the |var buttons = [addButton];| below and just change this to be:
var buttons = [{
 ...
}];
since addButton isn't used elsewhere.
Attachment #800813 - Flags: review?(jaws) → review+
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
https://hg.mozilla.org/mozilla-central/rev/a4e9c9c9dbf9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Blocks: 921877
You need to log in before you can comment on or make changes to this bug.