[Keyboard][V1.2] The number keyboard still can work after disabling it.

RESOLVED DUPLICATE of bug 912007

Status

Firefox OS
Gaia::Keyboard
RESOLVED DUPLICATE of bug 912007
4 years ago
4 years ago

People

(Reporter: whsu, Assigned: arthurcc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [FT:System-Platform], [Sprint:3])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 799322 [details]
Number Keyboard

* Description:
  This problem happens on v1.2 build(M-C).
  If user disabled the number keyboard, the FxOS still pop-up the number keyboard while the field property is "Number".
  As I check the code logic with Gary C., it makes sense to pop up the number keyboard.
  But I think the behavior will confusing user since the number keyboard is disabled.
  Attaching the screenshot.

* Reproduction steps:
  1. Disabling the number keyboard on keyboard settings page
  2. Launch the contact app
  3. Tap "Phone" field
 
* Expected result:
  The text keyboard is poped up

* Actual result:
  The number keyboard is poped up

* Reproduction build:(Mozilla-central-unagi-eng/2013-09-02-04-02-02)
  + Mercurial-Information
    - Gecko revision="0457c197a382a219b1050fd2ccfddfdbbdad7a92"
  + Git-information
    - Gaia revision="1179318fb5aa"
  + Gecko version: 26.0a1
(Reporter)

Updated

4 years ago
blocking-b2g: --- → koi?
Whiteboard: [FT:System-Platform], [Sprint:3]
(Reporter)

Updated

4 years ago
Depends on: 891673

Comment 1

4 years ago
Need to fix it.
Assignee: nobody → arthur.chen
blocking-b2g: koi? → koi+

Comment 2

4 years ago
Should we perhaps take a similar tactic to the settings interface for disabling all the keyboards automatically re-enabling the default?

If you turn off all number keyboards, it turns itself back on?

Comment 3

4 years ago
Same root cause of 912007
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 912007
You need to log in before you can comment on or make changes to this bug.