Space in email ID in account wizard creates new strange account (which cannot be removed!)

VERIFIED FIXED in mozilla0.9.4

Status

SeaMonkey
MailNews: Account Configuration
--
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: racham)

Tracking

Trunk
mozilla0.9.4
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Awaiting r=)

Attachments

(5 attachments)

Build ID:  2001-07-17-05-0.9.2, Windows 2000.

Summary: Space in email ID in account wizard creates new strange account.

Steps to Reproduce:

1.  Create a new profile, launch mail.
2.  Invoke the Account Wizard, choose, "Newsgroup" option.
3.  Enter your name.
4.  In the email section, enter your username, with a space before and after @.
 eg: stephend <space> @ <space> netscape.com (to avoid spam)
5.  Walk through the rest of the wizard, entering usual server information.
6.  Click Finish.
7.  Click in the Folder Pane on the account level, subscribe to a couple or more
newsgroups.
8.  Expand the account, and click on the newsgroup level.

Expected Results:

Newsgroups are subscribed to and updated with regards to count information (and
then the postings are displayed in the 3 pane window.)

Actual Results:

A new *account* will be created, in the following form:  <email ID>%20 on
<newsserver>.

Above, this strange-appearing account with newsgroups is the only one that
displays messages.
The one you'd expect to work, set up in step # 5, doesn't contain messages or
counts. 

Also, the account wizard keeps popping up (we know it does this for a new
account, but we've already setup the accounts).
Note: This account the stephend%20 on news.mozilla.org cannot be removed from
the account manager.
Created attachment 42693 [details]
3 pane's exhibited behavior
Created attachment 42694 [details]
Blank item for original news account.

Updated

17 years ago
Assignee: sspitzer → racham
Component: Mail Window Front End → Account Manager
QA Contact: esther → nbaca

Comment 4

17 years ago
I couldn't reproduce. The only "unusual" thing to do is to enter space before
and after the @ sign, right?

I got an account that 1) just had the name "test.example.net" and 2) was
removable. I assume I didn't understand/apply the correct steps to reproduce...
*** Bug 91289 has been marked as a duplicate of this bug. ***
If this is an easy fix, can we get this into the branch?
Keywords: nsbeta1

Comment 7

17 years ago
I was able to reproduce this easily as well using the form,
stephend @ netscape.com.

Comment 9

17 years ago
I don't think this is a branch bug but I do agree it's a good one to look into.

Comment 10

17 years ago
I think it's late for this on the branch.
right, too late for the branch.

what we need to do is extend validateEmail() in aw-identity.js not allow spaces
(or tabs, etc.)

see hostnameIsIllegal() in aw-server.js for how made prevent problems with
illegal hostnames.  

there might be more ways illegal chars (including whitespaces) can hork us up.

Comment 12

17 years ago
Taking, I have a fix.
Assignee: racham → hwaara

Comment 13

17 years ago
Created attachment 43839 [details] [diff] [review]
well-tested fix

Comment 14

17 years ago
Ignore the edits to smtpEditOverlay.xul

Comment 15

17 years ago
Created attachment 43841 [details] [diff] [review]
fix w/o smtpEditOverlay change
Keywords: nsBranch

Comment 16

17 years ago
Two weeks without review.  Bhuvan, Seth?
Status: NEW → ASSIGNED

Updated

17 years ago
Whiteboard: Awaiting reviews
Target Milestone: --- → mozilla0.9.4
+function validateEmail() { dump("validateEmail():");

remove that dump statement, and then sr=sspitzer   

Comment 19

17 years ago
Created attachment 45730 [details] [diff] [review]
New patch without dump()

Comment 20

17 years ago
Could someone r= this patch (sr=sspitzer) please?

Thanks
Whiteboard: Awaiting reviews → Awaiting r=

Comment 21

17 years ago
r=varada

Comment 22

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 23

17 years ago
Build 2001-08-15-04: WinMe
Build 2001-08-15-08: Mac 9.04, Linux RH 6.2
Verified Fixed. Now if the email address has spaces it does not allow you to
continue through the wizard.
Status: RESOLVED → VERIFIED

Comment 24

17 years ago
I am having difficulty with this same issue.  However, instead of just white
space, it's with plussed email addresses.  [For those who don't know: Sendmail
apparently has a feature (I didn't enable it; the admin did) by which the
username portion of an email address can contain a plus after it and then
mostly-arbitrary text.  Everything then between the + and @ are (I think)
stripped out of the address, and the mail goes on its merry way, see my email
address (jap3003+bugzilla@ksu.edu) for example].

I've been using this for a while, and have been having difficulties with it. 
Apparently, all non-alphanumeric characters [probably more; I haven't looked
into it] are translated into %xx, and a new news account is created with this
name as soon as I click on one of the newsgroups.  All messages from the
newsgroups go into this new account.  And, naturally, if I click on the
newsgroup under this *new* account, *another* account is created, but with %25
prepended to the %xx from before (the % from before), and the % is stripped out.
 This click-and-creation can go on ad infinitum.

What's more, if the news account is deleted and then another is re-created with
exactly the same server [even with a different name], then the little
expand/contract arrow appears beside the account settings, but nothing is
displayed at first.  If the account is contracted, then expanded again, <i>the
old subscribed newsgroups return</i>.  Regardless of the new email address, the
old "user%xx on server" "accounts" come back just as before, when one clicks on
the newsgroups.

Futhermore, an error comes up saying, essentially, that there are too many
connections to the news server.

Please forgive me for reopening this bug if it's a different one, but it looks
to me right now to be the same one.

Oh, yeah.  Browser info:  Windows NT/Service Pack 6a + "Security Rollup",
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3+) Gecko/20010831Mozilla 0.9.3+
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 25

17 years ago
Yes, I can see the weird behaviour with '+' as well.

My patch merely prevented some bad, invalid email accounts from getting through
the tests, not fixing the underlying problem that you describe.

I'll try and debug this tomorrow, to see if I can get provide any useful hints.
Reassigning for now back to racham.
Assignee: hwaara → racham
Status: REOPENED → NEW

Comment 26

17 years ago
Racham - Have you got the reviews for this one? 

Comment 27

17 years ago
Uhm, reviews? The patch attached was checked in by me, but the original problem
obviously remains in the backend...
hwaara / racham, can you open a new bug on the "+" issue and mark this fixed, to
get this bug off the radar?
fixed.  I'll go open the new bug.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 31

17 years ago
Verified, since a new bug was open for the "+" issue.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.