Closed Bug 912610 Opened 8 years ago Closed 6 months ago

PointerLock letting mouse leave the browser window when captured

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

23 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 853160
Tracking Status
firefox23 --- affected

People

(Reporter: mbest, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: parity-chrome, Whiteboard: [games:p?])

When playing the HelloRun demo, the game asks you to lock the mouse.  This is not done in fullscreen.  After agreeing, the game begins.  Moving the mouse to far up or down causes the mouse to leave the browser and the cursor become visible and able to interact with the OS GUI and menu bars, effectively unlocking the mouse while it's outside of the browser window.  Expected behavior is that the mouse is locked to the game window, therefor never being able to move outside of the browsers bounds.


Repro:
Go to the following link: http://hellorun.helloenjoy.com/
Click on the game to start.
Agree to have your mouse lock.
Move the mouse down until the mouse appears under the broswer window.
Whiteboard: [games:p1]
I tested it in Firefox 23 on Windows and it seems to only happen on Mac OS X.  I'm on Lion specificly.
I believe this is a dup, at least this was discussed in some bug.
Someone with a Mac should look at this.
Depends on: 912606
Currently can't test it on Nightly due to a blocker.
Also can't test on Aurora and Beta due to 912606 blocking the game from running.
Whiteboard: [games:p1] → [parity-chrome] [games:p1]
Can reproduce on Mavericks on Beta 26 and Nightly 28. That bugged me a while ago as well.
Whiteboard: [parity-chrome] [games:p1] → [parity-chrome] [games:p?]
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Keywords: parity-chrome
Whiteboard: [parity-chrome] [games:p?] → [games:p?]
Component: Event Handling → User events and focus handling
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853160
You need to log in before you can comment on or make changes to this bug.