[B2G][Buri 1.2][Vibrate]Device does not vibrate when headphones are plugged in

RESOLVED WONTFIX

Status

Firefox OS
Vendcom
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: gbennett, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [POVB])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 799859 [details]
VibrateHeadphonesLog.txt

Description:
After plugging a 3.5mm jack into the headphone slot, all vibration ceases and if headphones are already plugged in the phone does not vibrate at all.

Repro Steps:
1) Updated Buri to Build ID: 20130904040205
2) Turn vibrate on in the settings and the volume rocker.
3) Call the device and wait for it to vibrate.
4) Plug in headphones.

Actual:
Vibration stops.

Expected:
Vibration continues whether headphones are plugged in or not.

Environmental Variables
Build ID: 20130904040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ff96bd19c1c
Gaia: b6c5bf1d24230bfed4a8f680e625fa2175001f82
Platform Version: 26.0a1

Notes: I was able to repro the issue for alarms and incoming calls.
Repro frequency: 5/5
See attached: VibrateHeadphonesLog.txt

Updated

5 years ago
Keywords: regression, regressionwindow-wanted

Updated

5 years ago
QA Contact: laliaga

Comment 1

5 years ago
Went as far back as the buildshare went for Buri Master (6/21) and it didn't vibrate with headphones plugged in. Also tested on the latest Leo which did vibrate with headphones plugged in. 

- Latest Leo - No repro -
Environmental Variables
Build ID: 20130905041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c5937a004145
Gaia: 2529db165272ac53bfcb3b426be884e4e86dde89
Platform Version: 18.1

- Buri Master 6/21 - Repros -
Environmental Variables
Build ID: 20130621031231
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ba8c86f1a56
Gaia: e2f19420fa6a26c4287588701efaec09a750dba1
Platform Version: 24.0a1
Keywords: regressionwindow-wanted

Updated

5 years ago
blocking-b2g: --- → koi?
QA,

Please check after what bug landing has created this bug to occur?
Keywords: qawanted
(In reply to Preeti Raghunath(:Preeti) from comment #2)
> QA,
> 
> Please check after what bug landing has created this bug to occur?

The regression window above indicates this is present all the way back on 6/21, is the farthest we'll go back regression window wise. This just means this has been present on 1.2 before 6/21, but is working on 1.1. So we will not have a bug to check here - getting a regression window greater than 3 months out on B2G is going to be too helpful, anyways (too many things changed by then).

Clearing qawanted as there's nothing to do here from what I can see.
Keywords: qawanted
Fabrice,

This seems to be an issue in 1.2.

Can you please check the code and reassign appropriately?
Flags: needinfo?(fabrice)
Is this confirmed to be buri specific?
Flags: needinfo?(fabrice)
(In reply to Fabrice Desré [:fabrice] from comment #5)
> Is this confirmed to be buri specific?

QA Wanted - Can we test to see if this reproduces on a different target device?
Keywords: qawanted

Comment 7

5 years ago
I have only two devices Buri and Leo for the test, so leaving the QA Wanted, for those who can reproduce the issue on other devices
As mentioned in the comment 1 the issue reproduces on Buri and doesn't on the latest Leo 

The issue reproduces on the latest Buri v 1.2 Aurora Mozilla RIL
Build ID: 20131001004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/5689e4237ab7
Gaia: 5e0d0df6a762cf1e1812eeb735fba72e2539dc0c
Platform Version: 26.0a2
Firmware reversion: US_20130912

Device: (Leo v 1.1.0 COM/RIL)
Build ID: 20131001041206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 02b975e6ce12922928c74276ac7d19432a03f126
Platform Version: 18.1
RIL Version: 01.01.00.019.240 
Firmware Version: D300

Comment 8

5 years ago
It is device specific issue:
 - reproduces consistenly on Buri aurora
 - does not reproduce on Leo aurora
 - does not reproduce on Ikura aurora 

It is NOT a regression:
 - reproduces on all Buri 1.2 builds, see comment 1
 - reproduces on latest Buri v1.1 

Buri v1.1:
Gaia   e5adcf3c23b6709a51087539bc4cdb67683ca4a0
SourceStamp c630289d6388
BuildID 20131004041201
Version 18.0
Keywords: qawanted, regression
Sounds like this is a vendor-specific bug.
blocking-b2g: koi? → ---
Component: General → Vendcom
Whiteboard: [POVB]
Flags: needinfo?(vchen)
remove my ni? for this old Buri 1.2 bug
Flags: needinfo?(vchen)
Just a FYI this still happens, Vance.

Should we mark as WONTFIX?
status-b2g-v1.3: --- → affected
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
Flags: needinfo?(vchen)
thanks for the reminder Naoki, and yes i think this one is WONTFIX since Fire C/Fire E all has the same behavior and personally i don't see there is anything wrong with not vibrate while inserting the headphones
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(vchen)
Resolution: --- → WONTFIX

Updated

4 years ago
Duplicate of this bug: 945271
You need to log in before you can comment on or make changes to this bug.