Closed Bug 912796 Opened 7 years ago Closed 7 years ago

[Buri][Camera][Call]Incoming a call interface display abnormal during taking photos

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect, P1)

defect

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed
b2g-v1.2 --- fixed

People

(Reporter: sync-1, Assigned: alive)

Details

(Whiteboard: [systemsfe])

Attachments

(5 files)

Firefox os  v1.1
 Mozilla build ID:20130828041203
 
 Created an attachment (id=509511)
 log
 
 DEFECT DESCRIPTION:
  Open camera in lock screen,incoming a call ,interface disorder
  REPRODUCING PROCEDURES:
  1.Set up a passcode lock then lock the phone
  2.Unlock the phone and enter into camera from lock screen
  3.Incoming a call find interface disorder-->KO
 
  EXPECTED BEHAVIOUR:
  ko:interface display normal
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
  Free test
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  High
 
  REPRODUCING RATE:
  5/5
 
  For FT PR, Please list reference mobile's behavior:
Clone from brother
Attached file video2
Clone from brother
Attached file log
Clone from brother
Attached file video1
blocking-b2g: --- → leo?
QA,

Please check if this is a regression from 1.0.1.
Keywords: qawanted
QA Contact: sparsons
Able to reproduce on the Buri and Unagi Device 1.0.1 Build ID: 20130906043205

Environmental Variables
Build ID: 20130906043205
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
Gaia: 054cdc27404e2daca91d3065d9783681032b2151
Platform Version: 18.0

If the user receives a call while in Camera mode, the the incoming call interface displays weird. part of the Camera appears above the number being displayed and the home screen appears below the number. 

See screenshot attached above.
Keywords: qawanted
Attached image Buri_Unagi_09062013
Hema,

The issue seems to be reproducible.

Please reassign within your team.
Assignee: nobody → hkoka
Flags: needinfo?(hkoka)
Looks like a home/lock screen display issue. Assigning to Gregor to find the right person who can address this.
Flags: needinfo?(hkoka)
Whiteboard: [systemsfe]
Taken.
Assignee: hkoka → alive
WIP
https://github.com/mozilla-b2g/gaia/pull/12148

Haven't tested on device but it shall work.
Hi Alive, if I am recording a video, a call coming, how does the camera?
(In reply to Mingming ZHAO from comment #14)
> Hi Alive, if I am recording a video, a call coming, how does the camera?

Good question, with the patch it would be discarded. So what's expected? The screen looks strange because callscreen is transparent at middle section.
If we prefer to reserve the camera recording, we shall not do anything to this bug.
Maybe can save the recording first, then close camera, display incoming call interface.
(In reply to Mingming ZHAO from comment #16)
> Maybe can save the recording first, then close camera, display incoming call
> interface.

No, we don't have the way to let camera app knows call is happening. And saving does take time I think.
(In reply to Alive Kuo [:alive] from comment #17)
> (In reply to Mingming ZHAO from comment #16)
> > Maybe can save the recording first, then close camera, display incoming call
> > interface.
> 
> No, we don't have the way to let camera app knows call is happening. And
> saving does take time I think.

Yeah we don't want to deal with saving a video when we have an incoming call.
It takes a long time and during incoming calls we also put every other app in a low priority mode.
(In reply to Gregor Wagner [:gwagner] from comment #18)
> (In reply to Alive Kuo [:alive] from comment #17)
> > (In reply to Mingming ZHAO from comment #16)
> > > Maybe can save the recording first, then close camera, display incoming call
> > > interface.
> > 
> > No, we don't have the way to let camera app knows call is happening. And
> > saving does take time I think.
> 
> Yeah we don't want to deal with saving a video when we have an incoming call.
> It takes a long time and during incoming calls we also put every other app
> in a low priority mode.

So it seems unloading the lockscreen secure camera app when call is coming is the only solution right now.
Mingming ZHAO: Could you accept this?
(In reply to Alive Kuo [:alive] from comment #19) 
> So it seems unloading the lockscreen secure camera app when call is coming
> is the only solution right now.
> Mingming ZHAO: Could you accept this?

So I think I must accept.Thanks for your support. :)
> Yeah we don't want to deal with saving a video when we have an incoming call.
> It takes a long time and during incoming calls we also put every other app
> in a low priority mode.

In addition, in lockscreen the camera app is in system, and the system app can not been degrade to low priority even there is a call coming. So the second reason maybe not correct.
Component: Gaia::Dialer → Gaia::System::Lockscreen
Summary: [Buri][Home screen][Camera][Call]Incoming a call interface display abnormal during taking photos → [Buri][Camera][Call]Incoming a call interface display abnormal during taking photos
Switch panel when call state changed.
Attachment #804289 - Flags: review?(timdream)
Attachment #804289 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/commit/669b4b40972ae008b26270557a393383ae094a2b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
https://bugzilla.mozilla.org/show_bug.cgi?id=915468#c13
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Exactly the fail of unit test doesn't mean something is failing here.
It's because of leaking DOM element #lockscreen in the unit test. Trying to amending.
Fixed and merging again...though travis stops working now so I couldn't double check. cross finger..
https://github.com/mozilla-b2g/gaia/commit/7de1cd3e46d60f1070a458613a21511b676b603b
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
blocking-b2g: leo? → leo+
Which commit(s) should be uplifted?
Flags: needinfo?(alive)
Uplifted 4fca449306951a2a602f30555ed6ca3d803aae03 to:
v1-train: cba293d2a191b9a209edef65493ecb57314b4ca5
v1.2 already had this commit
v1.1.0hd: cba293d2a191b9a209edef65493ecb57314b4ca5
You need to log in before you can comment on or make changes to this bug.