[Settings] User can change the PIN code in'Change PIN' menu when SIM state is 'pukRequired'

RESOLVED DUPLICATE of bug 897310

Status

Firefox OS
Gaia::Settings
RESOLVED DUPLICATE of bug 897310
4 years ago
4 years ago

People

(Reporter: Leo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 799909 [details] [diff] [review]
simcard_dialog.patch

[STR]
1. SIM lock is enable
2. Try to unlock and input the wrong PIN code 3 times
3. Close the PUK screen
4. Go to 'Change PIN'

You can chage the PIN code without PUK code


I uploaded a patch. 
User can change PIN code after input PUK code.

Please check it
(Reporter)

Updated

4 years ago
Attachment #799909 - Flags: review?(ehung)
Comment on attachment 799909 [details] [diff] [review]
simcard_dialog.patch

r=me. Thanks for the patch, but I'm afraid that it's not properly solve the bug.
This patch force displayed screen to be 'unlock' but doesn't update user action to correct 'unlock' state, that may lead to an inconsistency. Furthermore, this transition is not smooth and I think it's better to redirect user to unlock puk screen when the user clicking on "change pin" button.
BTW, please use `IccHelper.cardState` instead of `this.mobileConnection.cardState`, we do a run-time detection in IccHelper to know which interface we should query.
Attachment #799909 - Flags: review?(ehung) → review-
(Reporter)

Comment 2

4 years ago
Thanks for review.
`IccHelper.cardState` do not use in v1-train.

This issue should be fixed in the next version of leo.
This patch was temporary to fix quickly and not applied in leo.

Please check this issue.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 897310
You need to log in before you can comment on or make changes to this bug.