[Gallery] Partial back out of bug 903944 - Remove the local copy of the blob before opening an image

RESOLVED FIXED

Status

Firefox OS
Gaia::Gallery
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: graziani, Assigned: graziani)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
We should remove the workaround from bug 903944 once we have the bug 908432 fixed.

This is based on comments from these two bugs which say that the workaround in Gaia is considered expensive, and the new Gecko patch solves the problem.

The back out should be partial, because part of that also fixes bug 908126.
(Assignee)

Updated

4 years ago
Depends on: 908432
(Assignee)

Comment 1

4 years ago
Created attachment 799966 [details] [diff] [review]
Patch 1 - Partial back out of bug 903944

This patch backs out the workaround for the crash from bug 903944, and keeps the fixes related to small preview display.
Comment on attachment 799966 [details] [diff] [review]
Patch 1 - Partial back out of bug 903944

Review of attachment 799966 [details] [diff] [review]:
-----------------------------------------------------------------

This patch looks like it cleanly removes the workaround.  Thanks for coming back to this.

I looks like the gecko fix in bug 908432 has not been uplifted to b2g18, so don't uplift this to v1-train unless the gecko patch is uplifted first.
Attachment #799966 - Flags: review?(dflanagan) → review+
I think the plan is to take this. Requesting approval.
Status: UNCONFIRMED → ASSIGNED
blocking-b2g: --- → leo?
Ever confirmed: true
Ben

Please provide risk analysis.
Flags: needinfo?(bent.mozilla)
I didn't have anything to do with this patch really so I can't answer. David, can you help here? (https://bugzilla.mozilla.org/show_bug.cgi?id=908432#c1 is what I'm referring to).
Flags: needinfo?(bent.mozilla) → needinfo?(dflanagan)
Bug 903944 added a workaround for a gallery crash, and was uplifted to v1-train.

Bug 908432 fixed the underlying cause of the crash in gecko and has been uplifted to b2g-18.

This bug removes the workaround.  If we don't uplift it to v1-train, we'll be running an unnecessary workaround and the Gallery View activity will use more memory and be a little less responsive than it would be otherwise.

The risk here is that verifying that bug 903944 is still gone after removing the workaround will be difficult because it is a corner case only triggered by very specific images.  See https://bugzilla.mozilla.org/show_bug.cgi?id=903944#c35 for verification requirements.
Flags: needinfo?(dflanagan)
This bug comes late in the game. It seems we could live with it. Not a release blocker
blocking-b2g: leo? → -
Andre,

Even though this bug did not get uplift permission, it should still have landed to master. I'm setting needinfo on you just to bring that to your attention.

Closing this bug, however, because bug 917387 will remove the workaround on master and v1.2.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Flags: needinfo?(andre.graziani)
(Assignee)

Comment 9

4 years ago
(In reply to David Flanagan [:djf] from comment #8)

Sorry, I should have uplifted it to master.
bug 917387 did that, so no more action is required for now.
Flags: needinfo?(andre.graziani)

Updated

4 years ago
Assignee: nobody → andre.graziani
You need to log in before you can comment on or make changes to this bug.