M092 N610 plugin crash using [@ RealPlayerG2][@ AppleJava]

VERIFIED WORKSFORME

Status

Plugins Graveyard
RealPlayer (Real)
P2
critical
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: greer, Assigned: Peter Lubczynski)

Tracking

({crash, qawanted, topcrash})

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
These two crashes have both shown up in the M092 talkback data in the last week. 
I recognize that there is not much to go on, (and they may be separate bugs). 
Because of the high profile nature of crashes with these plugins I'm going to 
log it.
Wondering out loud if they share a problem related to 
nsPluginHostImpl::InstantiateEmbededPlugin.

Sorry there isn't any more info.

Stack Trace: 

         RealPlayerG2 Plugin + 0x1bbc0 (0x3d23d5d0)
         RealPlayerG2 Plugin + 0xf038 (0x3d230a48)
         nsPluginHostImpl::InstantiateEmbededPlugin()   [nsPluginHostImpl.cpp  
line 2908]
         nsObjectFrame::InstantiatePlugin()     [nsObjectFrame.cpp  line 1076]
         nsObjectFrame::Reflow()        [nsObjectFrame.cpp  line 902]     
(32839591)    Comments: Opening a real audio stream

--------
         AppleJava + 0x40e70 (0x0bc04f10)
         AppleJava + 0x40f78 (0x0bc05018)
         JManager2 + 0x79b0 (0x0bcc9060)
         JManager2 + 0x82d4 (0x0bcc9984)
         JManager2 + 0x8594 (0x0bcc9c44)
         JManager2 + 0x864c (0x0bcc9cfc)
         MRJPlugin + 0x9080 (0x0bdfa2f0)
         MRJPlugin + 0xe40 (0x0bdf20b0)
         MRJPlugin + 0x6c8 (0x0bdf1938)
         nsPluginHostImpl::SetUpPluginInstance()        [nsPluginHostImpl.cpp  
line 3211]
         nsPluginHostImpl::InstantiateEmbededPlugin()   [nsPluginHostImpl.cpp  
line 2855]
         nsObjectFrame::InstantiatePlugin()     [nsObjectFrame.cpp  line 1076]     
(32910574) URL: www.yahoo.com
(32910574) Comments: I was reading a bunch of new articles
(Reporter)

Comment 1

17 years ago
Adding keywords for talkback tracking and QA help
Keywords: crash, qawanted, topcrash

Comment 2

17 years ago
Peter, do you remember seeing stack trace like this? URL would be helpful too.
(Assignee)

Comment 3

17 years ago
This could depend on bug 90959 and it looks Mac-only.
(Assignee)

Comment 4

17 years ago
Mac plugin bug---->peterl
Assignee: av → peterlubczynski
(Assignee)

Comment 5

17 years ago
Does talkback still show this crash in recent builds? It may be a dup of another
bug. The entire stack may need to be examined to locate the correct bug.
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.5

Comment 6

17 years ago
I've had several complete system freezes attempting to view embedded RealPlayer
videos using Netscape 6.1 on OS 9.2.1 -- see these TalkBack incident IDs if
necessary:

TB35716644W
TB35717262W
TB35735218W

I believe that all of these were on the Big Brother 2 web site
(http://www.cbs.com/primetime/bigbrother2/), but considering that CNet is not
allowing Netscape 6.x browsers access to its RealPlayer videos, there's probably
a more significant problem than the site itself.
(Assignee)

Comment 7

17 years ago
Stack shows something going wrong in Paint(). I'd be nice to have a consistant
way to reproduce.

NQD + 0x19820 (0x3f883b70)
InterfaceLib + 0x1e7b8 (0xffd0f828)
NQD + 0x18c8c (0x3f882fdc)
InterfaceLib + 0x1ddf8 (0xffd0ee68)
embedgui60.dll + 0xb8c0 (0x3d6b3280)
RealPlayerG2 Plugin + 0x55e4 (0x3dce0e74)
RealPlayerG2 Plugin + 0xe350 (0x3dce9be0)
ns4xPluginInstance::HandleEvent() [ns4xPluginInstance.cpp, line 932]
nsPluginInstanceOwner::Paint() [nsObjectFrame.cpp, line 3046]
nsObjectFrame::Paint() [nsObjectFrame.cpp, line 1411]
PresShell::Paint() [nsPresShell.cpp, line 5300]
VIEW_DLL + 0x592c (0x3cd1830c)
VIEW_DLL + 0x1167c (0x3cd2405c)
VIEW_DLL + 0x11470 (0x3cd23e50)
VIEW_DLL + 0x10244 (0x3cd22c24)
VIEW_DLL + 0x12c70 (0x3cd25650) 
Priority: P1 → P2

Comment 8

17 years ago
Here are my steps:

1) Have the latest RealPlayer (8.something) installed on your computer with the
files "RealPlayerG2 Plugin" and "RealPlayerG2 Plugin.xpt" in the Plug-ins folder.
2) Launch Netscape 6.1 and open a new Navigator window.
3) Go to http://www.cbs.com/primetime/bigbrother2/ (while it remains -- the show
ended last week).
4) Click on "Click here to watch the complete, un-aired Big Brother Episode No.
28" towards the bottom right of the page, to the left of the poll.
5) On the small popup window, click the camera icon beside "Act 1 - Part 1."
6) Watch as a smaller popup window loads and the Real icon loads where the movie
should soon begin to play.
7) Once your hard disk ceases to click, try moving your cursor.  Uh oh!
8) Try to force quit via option-command-escape.  Nothing.  Oh no!
9) Try the programmer's box button.*  Still nothing.  Yikes!
10) Press the reset button and wait as your computer scans the hard disk for
damage and then loads the startup extensions and control panels.

* Note:  I do not have MacsBug installed, so it may be possible that MacsBug
could do something more useful upon pressing said button.
(Assignee)

Comment 9

17 years ago
Hm...using this fairly old build 2001090305, this works for me. I bet this has
been fixed in recent builds.

Reporter: Try with Mozilla 0.9.4 and those files should be copied to your
components folder.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 10

17 years ago
Peter,

I think I will try a nightly once the blank window / dialog box problem is
resolved.  (Until then I cannot be sure that my testing will actually function,
and I'd rather not go to the trouble of downloading Mozilla on my 33.6K
connection if it's not going to work anyway.)  I had Mozilla 0.9.4 installed at
once time, but it had a nasty lag for every page I loaded (I know 33.6K
connections aren't blazing, but Netscape 6.1 feels faster loading pages anyway),
so I chunked it.

As far as "those files should be copied to your components folder" is concerned,
I'm not quite certain what you mean.  Am I to somehow install 0.9.4's components
over those of Netscape 6.1?  I've always installed Mozilla independently of 6.1
and am not sure that I want to go mixing and matching however much the two may
have in common.

Tommy

Comment 11

17 years ago
Tommy, pls copy the nppl3260.dll and nppl3260.xpt from your 6.1 components 
folder to the mozilla 0.9.4 components folder (xpcom realplayer plugin files). 
Also be sure to do "about:plugins" and see that the realplayer location points 
to the components folder under your 0.9.4 installation.Thx!

Comment 12

17 years ago
Shrirang wrote:
"Tommy, pls copy the nppl3260.dll and nppl3260.xpt from your 6.1 components 
folder to the mozilla 0.9.4 components folder (xpcom realplayer plugin files). 
Also be sure to do "about:plugins" and see that the realplayer location points 
to the components folder under your 0.9.4 installation.Thx!"

Things get stranger still... neither of these files are in the 6.1 components
folder.  Only one of the files exists on my hard disk -- nppl3260.xpt -- and
it's in System Folder > Extensions > Real.  The files actually placed in my 6.1
Plug-ins folder were "RealPlayerG2 Plugin" and "RealPlayerG2 Plugin.xpt";
placing these files in the Mozilla Components folder causes the same crash.  I
just did a clean RealPlayer download / install a couple of days ago, so one
would assume that the installer and files are fresh.

Why is my installation not getting the same plug-ins / locations as y'all's are?

Tommy

Comment 13

17 years ago
I guess you should have chosen 'Full' option when installing NS6.1. After full 
installation RealPlayer should be correctly installed, meaning those two files 
sitting in the Components folder.

Comment 14

17 years ago
Andrei,

It's been a while since 6.1 came out, so I can't really be sure which
installation I chose, but I'm pretty sure I went with "Recommended" rather than
"Full."  However, wouldn't it make more sense for the RealPlayer install itself
to include these files as well?  After all, there are Mozilla users who would
probably like to make use of embedded RealPlayer who may not have Netscape 6.1
installed as well.

Is there any place I can obtain these files by themselves without downloading
the whole shebang again?  My connection seems to be 31200 at best, 21600 at
worst (it's a free dialup service for university students here, so naturally
it's not blazingly fast) and downloading the whole thing again would put demands
on my computer when I need to be working on a ten page paper due tomorrow. 
(Over three pages down so far, plus an outline that should get me the rest of
the way.)  Of course, if you can wait until after I'm done with that work I can
try to download the whole thing again anyway (or get it onto a Zip disk from one
of the T3-equipped labs on campus).

I am also curious as to whether greer@netscape.com (my apologies for not knowing
your full name) has found this issue to be resolved for him / her as well.

Tommy

Comment 15

17 years ago
Created attachment 50809 [details]
Two files attached -- save this link and rename it to something.zip

Comment 16

17 years ago
Andrei,

Thanks for the files.  Here are my results.  All are tested under Netscape 6.1
as the Mozilla 0.9.4 branch build I downloaded has serious paint problems with
this site (the background loads pixel by pixel and reloads when new backgrounds
and images are drawn on top of it):

1) "RealPlayerG2 Plugin" and "RealPlayerG2 Plugin.xpt" in Plug-ins in Netscape
folder + two files attached placed in Components folder = freeze.
2) "RealPlayerG2 Plugin" and "RealPlayerG2 Plugin.xpt" + two files attached all
placed in Components folder = freeze.
3) Two files attached placed in Components folder + no RealPlayerG2 Plugin files
present in any Netscape-associated files = "Click here to download plug-in" message.

Unfortunately none of these combinations actually got the video to work for me.
 I think this'll have to be it for me for tonight for aforementioned time
concerns, but please feel free to keep the comments going as I will deal with
them when time permits.

On another (off the subject) note, would having Flash plug-ins in both the
System Folder > Internet Plugins folder and the Netscape folder > Plug-ins
folder cause neither plug-in to be recognized?  This same site does not seem to
recognize that Netscape 6.1 has Flash (although it does recognize Mozilla having
it, in which case Mozilla does not have the plug-in in its folder).

Tommy
(Reporter)

Comment 17

17 years ago
In answer to Tommy's previous question:
This crash appears 35 times in the N610 data and once in M094 (35440118).
(Updating summary.)
And it's Tom (Greer) decidedly a "he" ;)
Summary: M092 plugin crash using [@ RealPlayerG2][@ AppleJava] → M092 N610 plugin crash using [@ RealPlayerG2][@ AppleJava]

Comment 18

17 years ago
Tom,

Thanks, and sorry.  I actually think I'd read your full name somewhere in my
various Mozilla surfing.

I tried yet another approach at getting RealPlayer to work with Netscape 6.1 --
the Netscape Plug-in web site itself.  This launched a .xpi; certainly
Netscape's own chosen installer should work right, right?  Well, I went to the
Big Brother 2 site as usual, and this time loading the pop-up player page caused
Netscape 6.1 to crash -- better than a freeze, but still not what I want.
Upon inspecting my about:plugins I see that I have two RealPlayer plug-ins
recognized, one of them in the Components folder; I'm guessing this comes from
the attached files from this bug that I placed in there.  There are two
RealPlayer plug-in files in my Plug-ins folder now as well.

Suggestions?  I'd re-download 6.1, but there are signs that it's successor may
not be too far off, and I'd rather not have to go through too much downloading /
installing madness in such a short time.  ;-)

Comment 19

17 years ago
Okay.  I downloaded build 2001092803 (0.9.4 branch) and it's working much
better.  The page loading drag from the milestone and recent branch builds is
gone, as is the blank page / dialog problem.  The only problem I'd run into was
that the page kept jumping when I typed a space when entering comments on
another bug -- and apparently I've made some change (Classic -> Modern perhaps)
that has caused that problem to cease as well.

So... this build has yet to be touched by RealPlayer in any way, shape, or form.
 Any recommendations as to what files I should download / move / etc. to test
RealPlayer?

Here's hoping I will soon be able to see those videos for myself.  :-)

Comment 20

17 years ago
A complete installation of Netscape 6.2 allows the aforementioned site to
function just fine -- I can finally see the movies!

Comment 21

17 years ago
url reported by Tommybee works just nice on mac 9.2 using 1120 trunk .reverified 
Status: RESOLVED → VERIFIED

Comment 22

17 years ago
filed bug 111269 for a problem observed while verifying this.

Updated

8 years ago
Component: Plug-ins → RealPlayer (Real)
Product: Core → Plugins
QA Contact: shrir → real-player
Target Milestone: mozilla0.9.5 → ---
Version: Trunk → unspecified
Crash Signature: [@ RealPlayerG2] [@ AppleJava]
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.