Closed Bug 913116 Opened 11 years ago Closed 11 years ago

[Fig] top sites not displaying oft-used bookmarks

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

26 Branch
ARM
Android
defect
Not set
normal

Tracking

(fennec26+)

RESOLVED WONTFIX
Tracking Status
fennec 26+ ---

People

(Reporter: krudnitski, Assigned: Margaret)

References

Details

Attachments

(2 files)

here's what's happening with me. I had 4 pinned thumbnails, and 2 'open' slots.

I use facebook *all* the time. It is listed as a bookmark below the top sites thumbnails, which I am supposing means that I have bookmarked it (although if I'm totally honest, until I today, I *never* scrolled past the actual Top Sites thumbnails).

However, my two unpinned thumbnail slots still show not an oft-used bookmark (but a page I visit frequently) and a link to the AMO. I can tell you that I visit the AMO once every few months to test it out and it hasn't changed since Fig was implemented in nightly. Facebook is nowhere to be seen.
 
So this leads me to asset that Top Sites still aren't working properly.

Let me know what you need (if screen shots would help, etc)
Can you provide some details on the URLs of the facebook pages that are bookmarked vs the ones you visit often? I suspect those may be different, and that's what's causing those other non-facebook bookmarks to get ranked higher in our sorting algorithm.
(attachment added: screen shot for top sites)

4 pinned sites: telegraph.co.uk, guardian.com, bbc.co.uk/news, bbc.co.uk/history.
2 unpinned sites are showing: cbcnews.ca and addons.mozilla.org/en-US/android


(attachment added: screen shot for bookmarks)

Scrolling below my Top Sites thumbnails to my bookmarks, my top ones are:
- Desktop bookmarks [folder] (which I haven't gone into at all)
- bbc history - bbc history (http://www.bbc.o.uk/history/0/) which I haven't accessed via thumbnail nor bookmark in ages
- facebook (https://m.facebook.com/?ref...4940122&_user=827375390) which uses a 'default' favicon
- facebook (https://m.facebook.com/hom...oint%2F$_user=827375390) which uses a 'facebook' favicon
- Firefox start (about:home)
- Firefox: customize with add-ons (https://addons.mozilla.org/en-US/android)
- Firefox: about your browser (about:firefox)
- Firefox: support (http://support.mozilla.org/en-US/products/mobile)
- BBC news - home (http://m.bbc.co.uk/news)
- CBCnews.ca (http://www.cbc.ca/m/touch/news.html)

and that's it for bookmarks.

In case it's useful, My top history sites are:
- facebook (https://m.facebook.com/?refs...ww.facebook.com%2F&rdr) <- if you want the full url, let me know
- cbcnews.ca (http://www.cbc.ca/m/touch/myregion.html)
- facebook (https://m.facebook.com/?ref...ome.php?_user=827375390) <- if you want the full url, let me know
- bbc news UK (http://m.bbc.co.uk/news/uk)
- bbc news home (http://m.bbc.co.uk/news)
- bbc news English (http://m.bbc.co.uk/news/england)
- facebook https://m.facebook.com/?ref...ome.php?_user=827375390) <- if you want the full url, let me know
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 26+
(In reply to Karen Rudnitski [:kar] from comment #4)

Thanks for providing so many details. I'm going to respond here, but we can also talk more about this in person next week.

> 4 pinned sites: telegraph.co.uk, guardian.com, bbc.co.uk/news,
> bbc.co.uk/history.
> 2 unpinned sites are showing: cbcnews.ca and addons.mozilla.org/en-US/android

So the issue you're describing here is that these two unpinned sites aren't as useful as you would like. If things are working as they should be, the query for this should be returning your most "frecently" visited bookmarks.

> Scrolling below my Top Sites thumbnails to my bookmarks, my top ones are:
> - Desktop bookmarks [folder] (which I haven't gone into at all)
> - bbc history - bbc history (http://www.bbc.o.uk/history/0/) which I haven't
> accessed via thumbnail nor bookmark in ages
> - facebook (https://m.facebook.com/?ref...4940122&_user=827375390) which
> uses a 'default' favicon
> - facebook (https://m.facebook.com/hom...oint%2F$_user=827375390) which uses
> a 'facebook' favicon
> - Firefox start (about:home)
> - Firefox: customize with add-ons (https://addons.mozilla.org/en-US/android)
> - Firefox: about your browser (about:firefox)
> - Firefox: support (http://support.mozilla.org/en-US/products/mobile)
> - BBC news - home (http://m.bbc.co.uk/news)
> - CBCnews.ca (http://www.cbc.ca/m/touch/news.html)
> 
> and that's it for bookmarks.

So here's a case where user expectations might not be meeting reality... the bookmarks you're seeing here (excluding the Desktop bookmarks folder) are just your "mobile" bookmarks, meaning bookmarks you made from Firefox on your phone, sorted in no particular order. I looked into the code, and we really don't provide any sort order for the query, so off the top of my head I don't even know how these are ordered. I would think it would return bookmarks in the order they were added, but then I don't know why the default bookmarks aren't at the top... It would be a different bug, but maybe we should look into being more explicit about the ordering of the bookmarks here.

> In case it's useful, My top history sites are:
> - facebook (https://m.facebook.com/?refs...ww.facebook.com%2F&rdr) <- if you
> want the full url, let me know
> - cbcnews.ca (http://www.cbc.ca/m/touch/myregion.html)
> - facebook (https://m.facebook.com/?ref...ome.php?_user=827375390) <- if you
> want the full url, let me know
> - bbc news UK (http://m.bbc.co.uk/news/uk)
> - bbc news home (http://m.bbc.co.uk/news)
> - bbc news English (http://m.bbc.co.uk/news/england)
> - facebook https://m.facebook.com/?ref...ome.php?_user=827375390) <- if you
> want the full url, let me know

Are any of these sites bookmarks? A quick way to tell that in the UI is if there's a star on their entries in the history list. If they aren't bookmarks, by design, they're never going to show up in that top bookmarks grid.
We're changing the current bookmarks panel to be a 'Top Sites' again (see bug 917455). Closing this bug. Feel free to re-open if there's something about this bug that would still need attention.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: