Create a redirect for old hackasaurus users to goggles.webmaker.org

RESOLVED FIXED

Status

Webmaker
DevOps
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jacob, Assigned: pomax)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Hackasaurus.org has outdated branding, and the goggles installation there is a different server and I think is broken.

Time for a crafty redirect to goggles.webmaker.org

We'll have to decide if we want to redirect all published remixes into the MakeAPI but I have a feeling that it's arduous and maybe not worth it.

Comment 1

5 years ago
Yeah, I can't imagine migrating all published remixes into the MakeAPI to be a worthy endeavour.
Assignee: nobody → johns
Status: NEW → ASSIGNED
No, not worth it.  Do we have access to hackasaurus, though, so we can redirect?

Also - still looking for a solution for folks that have this in their bookmarks bar and who might try and use it.  Old bookmarklet no longer works due to mixed content.

Comment 3

5 years ago
Yes, it's hosted on MoCo IT so we should be able to switch things over with no issues.

Unfortunately, I can't see any solution for the mixed content blocker. Take a look at the bookmarklet script:

javascript:(function(){var%20script=document.createElement('script');script.src='http://webxray.hackasaurus.org/webxray.js';script.className='webxray';document.head.appendChild(script);})();

Basically, it creates a script element, points the src at the Goggles js, and then loads it. The mixed content blocker will prevent the loading of this script on any https domain. I thought that setting the HSTS header, which forwards all http: traffic to https: would fix it, but bug 838395 says that mixed content blocking gets applied before the HSTS header for both Firefox and Chrome.

That being said, the Goggles should still load for people hacking http: sites. Maybe we could replace the hackasaurus JS with a message that says "Your Goggles have been upgraded! Please head to https://goggles.webmaker.org to install them". We could do this in addition to redirecting hackasaurus.org > goggles.webmaker.org. If that's what we want to do, lets make this a meta bug.
Jbuck, yes I'd like to add that redirect notice to the old goggles as mentioned here.
(Reporter)

Updated

5 years ago
Whiteboard: mozfest

Comment 5

5 years ago
Hey guys, Just noticing we're still getting a wee bit of media confusion about our offerings here and there re: hackasaurus, (and Google Goggles? where'd they get that name from!?)

FYI (8th para):

http://www.commonsensemedia.org/educators/blog/how-to-teach-coding-in-your-classroom-even-if-you%E2%80%99re-a-novice-yourself

I'm all for this redirect.
We should also silently "upgrade" all installed Hackasaurus scripts to use the new Goggles code, that is, anyone who has the old bookmarklet, should automatically get the new stuff.  If the bookmarklet is this:

javascript:(function(){var%20script=document.createElement('script');script.src='http://webxray.hackasaurus.org/webxray.js';script.className='webxray';document.head.appendChild(script);})();

We should hijack http://webxray.hackasaurus.org/webxray.js to actually send the en-US version of the new Goggles, consider:

javascript:(function(){var%20script=document.createElement('script');script.src='https://goggles.webmaker.org/en-US/webxray.js';script.className='webxray';script.dataset.lang='en-US';script.dataset.baseuri='https://goggles.webmaker.org/en-US';document.body.appendChild(script);})();

We need to somehow automatically serve back the new https://goggles.webmaker.org/en-US/webxray.js when you ask for http://webxray.hackasaurus.org/webxray.js.

So this is maybe not just a DevOps bug.  Pomax?
Flags: needinfo?(pomax)
(Assignee)

Comment 7

5 years ago
I'd much rather hijack the code so that it doesn't fire up goggles, but fires up JS that effects a modal going "you're using an old version of the goggles! hackasaurus.org is now goggles.webmaker.org, get your new goggles over at etc. etc" rather than keep hackasaurus.org alive and have two places that need to stay in sync, when really we only have one file to serve.
Flags: needinfo?(pomax)
(Reporter)

Comment 8

5 years ago
Suggesting that we first redirect hackasaurus.org as soon as possible and figure out the code updates as needed.

We just had a big maker party in Bhopal and they all used hackasaurus.org - https://etherpad.mozilla.org/GGITM-webmaker-project

:Pomax - your idea seems good. Would it be possible to put an image with the new Goggles bookmarklet in that modal notification, that way they can just reinstall the new Goggles right on the spot by dragging the image bookmarklet into their toolbar without having to go to another page and install it there?
OK, Pomax.  If that's in scope then, could you take this on?
Assignee: johns → pomax
(Assignee)

Comment 10

5 years ago
should be doable.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 911016
pozfest
Whiteboard: mozfest
(Assignee)

Comment 13

5 years ago
Created attachment 820460 [details] [review]
https://github.com/mozilla/goggles.webmaker.org/pull/55

This is a dropin replacement for the webxray.hackasaurus.org/webxray.js file that people using the old bookmarklet will get. Rather than the old xray goggles, they will get an overlay notice that looks like this: https://monkeymagic.mywebmaker.org/thimble/test-redirector
Attachment #820460 - Flags: review?(thomas.park)
Attachment #820460 - Flags: review?(brett)
(Assignee)

Comment 14

5 years ago
if this looks good, I can request that hackasaurus.org redirects to goggles.webmaker.org instead, except for webxray.hackasauraus.org, which we will give a route so that webxray.hackasaurus.org/webxray.js points to this migration js file instead.
(Assignee)

Comment 15

5 years ago
previous link revealed a bug in thimble (file separately). Working link: https://thimble.mofostaging.net/en-US/project/352/remix
Comment on attachment 820460 [details] [review]
https://github.com/mozilla/goggles.webmaker.org/pull/55

Added comments about copy and style on the PR.
Attachment #820460 - Flags: review?(thomas.park) → review-
(Assignee)

Comment 17

5 years ago
updated as per suggestion on https://thimble.mofostaging.net/project/352/remix
(Assignee)

Updated

5 years ago
Attachment #820460 - Flags: review?(thomas.park)
Attachment #820460 - Flags: review?(brett)
Attachment #820460 - Flags: review-
Comment on attachment 820460 [details] [review]
https://github.com/mozilla/goggles.webmaker.org/pull/55

Looks good to go!
Attachment #820460 - Flags: review?(thomas.park) → review+

Comment 19

5 years ago
Commit pushed to master at https://github.com/mozilla/goggles.webmaker.org

https://github.com/mozilla/goggles.webmaker.org/commit/5af4e9337369fea6175c200c429899e80cc10db4
Merge pull request #55 from Pomax/bug913127

migration .js for people using an old copy of webxray.js
(Assignee)

Comment 20

5 years ago
landed into the repo.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Summary: Redirect hackasaurus.org to goggles.webmaker.org → Create a redirect for old hackasaurus users to goggles.webmaker.org
You need to log in before you can comment on or make changes to this bug.