debug builds on solaris 8 fail for trunk ...

RESOLVED DUPLICATE of bug 88703

Status

()

--
critical
RESOLVED DUPLICATE of bug 88703
18 years ago
18 years ago

People

(Reporter: girish.manwani, Assigned: scc)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Here is the point of failure...

/opt/SUNWspro/bin/CC -o nsFontMetricsXlib.o -c -DOSTYPE=\"SunOS5\"
-DOSARCH=\"SunOS\" -DMOZ_REFLOW_PERF -DMOZ_REFLOW_PERF_DSP -DOJI
-D_IMPL_NS_GFXONXP -DUSE_MOZILLA_TYPES -DUSE_XPRINT -D_IMPL_NS_XPRINT  
-I../../../dist/include -I../../../dist/include
-I/multipak/disk4/gmanwani/mozilla-sparc-nightly/mozilla/dist/include/nspr     
-I. -I./../xlib -I./../xlibrgb     -KPIC   -mt  -DDEBUG -DDEBUG_gmanwani
-DTRACING -g -I../dist/include
-I/multipak/disk4/gmanwani/mozilla-sparc-nightly/dist/lib/glib/include
-I/multipak/disk4/gmanwani/mozilla-sparc-nightly/dist/include  -DMOZILLA_CLIENT
-DBROKEN_QSORT=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1 -DD_INO=d_ino
-DMOZ_WIDGET_GTK=1 -DMOZ_ENABLE_XREMOTE=1 -DMOZ_DEFAULT_TOOLKIT=\"gtk\"
-DMOZ_X11=1 -DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_INT16_T=1
-DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1
-DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_SYS_BYTEORDER_H=1 -DHAVE_MEMORY_H=1
-DHAVE_UNISTD_H=1 -DHAVE_SYS_FILIO_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_X11_XKBLIB_H=1
-DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_SYS_VFS_H=1
-DHAVE_SYS_MOUNT_H=1 -DHAVE_LIBM=1 -DHAVE_LIBDL=1 -DHAVE_LIBSOCKET=1
-DHAVE_LIBPOSIX4=1 -D_REENTRANT=1 -DHAVE_RANDOM=1 -DHAVE_QSORT=1
-DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1
-DHAVE_LOCALTIME_R=1 -DHAVE_STATVFS=1 -DHAVE_MEMMOVE=1 -DHAVE_USLEEP=1
-DHAVE_RINT=1 -DHAVE_NL_LANGINFO=1 -DHAVE_GETTIMEOFDAY=1
-DGETTIMEOFDAY_TWO_ARGS=1 -DHAVE_DEV_ZERO=1 -DHAVE_IOS_BINARY=1 -DHAVE_OSTREAM=1
-DHAVE_CPP_EXPLICIT=1 -DHAVE_CPP_SPECIALIZATION=1
-DHAVE_CPP_MODERN_SPECIALIZE_TEMPLATE_SYNTAX=1
-DHAVE_CPP_PARTIAL_SPECIALIZATION=1 -DHAVE_CPP_ACCESS_CHANGING_USING=1
-DHAVE_CPP_AMBIGUITY_RESOLVING_USING=1 -DHAVE_CPP_NAMESPACE_STD=1
-DHAVE_CPP_UNAMBIGUOUS_STD_NOTEQUAL=1 -DHAVE_CPP_NEW_CASTS=1
-DHAVE_CPP_DYNAMIC_CAST_TO_VOID_PTR=1 -DNEED_CPP_UNUSED_IMPLEMENTATIONS=1
-DHAVE_I18N_LC_MESSAGES=1 -DMOZ_LOGGING=1 -DMOZ_MAIL_NEWS=1 -DMOZ_ENDER_LITE=1
-DNS_MT_SUPPORTED=1 -DIBMBIDI=1 -DDETECT_WEBSHELL_LEAKS=1
-DMOZ_USER_DIR=\".mozilla\" -DMOZ_XUL=1 -DINCLUDE_XUL=1 -DUSE_IMG2=1
-DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 -DUNIX_ASYNC_DNS=1 -DHAVE_MOVEMAIL=1
-DJS_THREADSAFE=1  ./../xlib/nsFontMetricsXlib.cpp
"/usr/include/strings.h", line 28: Error: Only one of a set of overloaded
functions can be extern "C".
"/usr/include/strings.h", line 28: Error: std::strchr(const char*, int),
returning char*, was previously declared returning const char*.
"/usr/include/strings.h", line 29: Error: Only one of a set of overloaded
functions can be extern "C".
"/usr/include/strings.h", line 29: Error: std::strrchr(const char*, int),
returning char*, was previously declared returning const char*.
Over to strings...
Assignee: asa → scc
Status: UNCONFIRMED → NEW
Component: Browser-General → String
Ever confirmed: true
QA Contact: doronr → scc

Comment 2

18 years ago
Sounds like X include fun... was fixed in recent Xsun patches. Please apply
recent Xsun patch from sunsolve and try again, please...

Comment 3

18 years ago
Looks like a DUPLICATE of bug 88703 ...
(Assignee)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 88703 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.