Build failure: Specified MOZCONFIG ".mozconfig-release" does not exist!

RESOLVED DUPLICATE of bug 913246

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 913246
4 years ago
4 years ago

People

(Reporter: markh, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

This started happening after I pulled today.

# CWD is the root of the tree.
# Use the same .mozconfig I always do...
$ export MOZCONFIG=.mozconfig-release

# Verify it exists.
$ ls -l $MOZCONFIG
-rw-r--r-- 1 skip Administrators 594 Aug  4 13:37 .mozconfig-release

# Attempt to build
$ ./mach build
 0:00.17 C:/mozilla-build/msys/bin/sh.exe -c c:/mozilla-build/python/python.exe o:/src/mozilla-git/central/build/pymake/make.py -f client.mk -s
 0:04.88 Adding client.mk options from o:/src/mozilla-git/central/.mozconfig-release:
 0:04.88     MOZ_OBJDIR=$(TOPSRCDIR)/obj-release
 0:04.88     MOZ_MAKE_FLAGS=-j12
 0:04.88     AUTOCLOBBER=1
 0:04.88     FOUND_MOZCONFIG := o:/src/mozilla-git/central/.mozconfig-release
 0:06.47 Clobber not needed.
 0:06.50 cd o:/src/mozilla-git/central/obj-release
 0:06.53 o:/src/mozilla-git/central/configure
 0:06.76 Specified MOZCONFIG ".mozconfig-release" does not exist!
 0:06.80 Fix above errors before continuing.
...

# Work-around - set MOZCONFIG to a FQ path:
$ export MOZCONFIG=/o/src/mozilla-git/central/.mozconfig-release

# Build now works
$ ./mach build
 0:00.17 C:/mozilla-build/msys/bin/sh.exe -c c:/mozilla-build/python/python.exe o:/src/mozilla-git/central/build/pymake/make.py -f client.mk -s
 0:03.21 Adding client.mk options from o:/src/mozilla-git/central/.mozconfig-release:
 0:03.21     MOZ_OBJDIR=$(TOPSRCDIR)/obj-release
 0:03.21     MOZ_MAKE_FLAGS=-j12
 0:03.21     AUTOCLOBBER=1
 0:03.21     FOUND_MOZCONFIG := o:/src/mozilla-git/central/.mozconfig-release
 0:04.82 Clobber not needed.
 0:04.86 cd o:/src/mozilla-git/central/obj-release
 0:04.89 o:/src/mozilla-git/central/configure
 0:06.16 Adding configure options from o:/src/mozilla-git/central/.mozconfig-release:
...
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 913246
You need to log in before you can comment on or make changes to this bug.