[wasabi] Changes of voice privacy setting won't be saved if reboot right after enable or disable it.

VERIFIED FIXED in 1.3 C1/1.4 S1(20dec)

Status

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: echu, Assigned: arthurcc)

Tracking

unspecified
1.3 C1/1.4 S1(20dec)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 verified)

Details

(Whiteboard: [FT:RIL])

Attachments

(3 attachments)

Posted file before reboot.
Voice privacy setting is always disabled after reboot device.

* Build Number                
Gaia:     f2ca2f21e75b7e1db4183960f69810422295c21f
Gecko:   2a2ff267b86346ae80e453a814c442da82583ab1
BuildID   20130905062051
Version   26.0a1

* Reproduce Steps
1. Enable Voice Privacy in Settings > Call setting.
2. Reboot device.

* Expected Result
Voice privacy stays enabled.

* Actual Result
Voice privacy is disabled.

* Occurrence rate
100%
Posted file after reboot.
Blocks: 890814
Blocks: 913331
No longer blocks: 913331
Summary: [wasabi] Voice privacy setting is always disabled after reboot device. → [wasabi] Voice privacy setting is always disabled after enable it and reboot device.
Whiteboard: [FT:RIL]
No longer blocks: 890814
Assignee: nobody → arthur.chen
blocking-b2g: --- → koi?
Need to fix it in v1.2
blocking-b2g: koi? → koi+
Update the title, the issue actually is that setting change won't take effect if reboot device right after save the change. It takes time to permanently saved.
Summary: [wasabi] Voice privacy setting is always disabled after enable it and reboot device. → [wasabi] Changes of voice privacy setting won't be saved if reboot right after enable or disable it.
Move to 1.3 since no CDMA needed in v1.2
blocking-b2g: koi+ → 1.3?
according to triage result, changed to 1.3+
blocking-b2g: 1.3? → 1.3+
Target Milestone: --- → 1.3 Sprint 6 - 12/6
Hsin-yi, does gecko keep the voice privacy setting after reboot?
Flags: needinfo?(htsai)
Target Milestone: 1.3 Sprint 6 - 12/6 → ---
Target Milestone: --- → 1.3 Sprint 6 - 12/6
No, gecko doesn't... (Weird, I thought I've replied the information at least twice...)
Flags: needinfo?(htsai)
Target Milestone: 1.3 Sprint 6 - 12/6 → 1.3 C1/1.4 S1(20dec)
Alive, Jose, could you help review the change? Thanks.
Attachment #8347129 - Flags: review?(josea.olivera)
Attachment #8347129 - Flags: review?(alive)
Comment on attachment 8347129 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/14639

It's good but I prefer that once we have a new module we have a test.
Attachment #8347129 - Flags: review?(alive) → feedback+
Comment on attachment 8347129 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/14639

Added unit tests for VoicePrivacySettingsHelper.
Attachment #8347129 - Flags: review?(alive)
Comment on attachment 8347129 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/14639

r+ with comments nits
Attachment #8347129 - Flags: review?(alive) → review+
Comment on attachment 8347129 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/14639

Thanks for the effort. I dont have a CDMA device to give a try. Left some comments on the PR. Take a look at them please.
Attachment #8347129 - Flags: review?(josea.olivera)
Comment on attachment 8347129 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/14639

Comments and nits are addressed. When getVoicePrivacyMode returns error, I use console.log when the device does not support the API. For other errors, console.error is used. The reason of doing this is that I don't want to get errors when calling to the API on gsm devices and which are most of the cases.

Could you take a look at it again? Thanks!
Attachment #8347129 - Flags: review?(josea.olivera)
Comment on attachment 8347129 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/14639

Reviewed again, LGTM. Thanks Arthur! r=me
Attachment #8347129 - Flags: review?(josea.olivera) → review+
Thank you guys. 

master: 8759f9916c119de88e62598d2451b2339011085a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Hi Arthur,

Verified on master build but there is another blocking bug 952386 that make me unable to verify it.
Gaia      a9b942c98a09eed626104e6509a4ba4f50842231
Gecko     bdc10edc8a2d48bba8a2ff011974309a4158bba4
BuildID   20131220100118
Version   29.0a1
Depends on: 952386
Uplifted 8759f9916c119de88e62598d2451b2339011085a to:
v1.3: e9ddebe506fd4af9f20038445e57e50ba647937d
Verified on Wasabi

Gaia      7fc5eb67ff0aedbeb6874f670891e8e9b4505a16
Gecko     2b1732ba02eb74ec81f54f19cd9ef81da6c12844
BuildID   20140116100919
Version   28.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.